Page 1 of 9 123 ... LastLast
Results 1 to 10 of 84

Thread: ZWS alpha2 feedback

  1. #1
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169

    ZWS alpha2 feedback

    We just downloaded the zws-1.0-alpha2.tar.gz from the portal, have SLES 11 SP3, installed all plus python modules, configured, but the service crashes on start:

    We added the python repo from to have the required python modules:
    - pyOpenSSL
    - python-daemon
    - python-dateutil
    - python-lockfile

    and updated everything, still no chance. What are we missing?
    Last edited by zmi1; 05-11-2013 at 06:25 AM.
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  2. #2
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Hi Michael,

    I discussed this with one of our developers today. It seems that SLS 11 SP3 is using python-lockfile in version 0.9 which introduced a bug in relation to python-daemon. We already made a ticket about this:

    For the meantime a downgrade to version 0.8 is recommended on SLES 11 SP3.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  3. #3
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    Thank you Felix, but there's no prepacked 0.8 version of that package:


    I tried the one from SP2, but it would produce the same results:

    Is there anything else I'd need to do after installing the 0.8 version?
    Last edited by zmi1; 05-11-2013 at 06:24 AM.
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  4. #4
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    More developer ping-pong ;-)

    Could it be that there were still traces of 0.9 in your system? We have tested this internally and it works find with 0.8 but not with 0.9.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  5. #5
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    Shouldn't, as I used rpms:

    But who knows? Is there anything I could check?
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  6. #6
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    any ideas? I'd like to test, but can't ATM.
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  7. #7
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    Just installed zws-1.0-alpha2_zcp7.1.8beta2, still not working!

    # /etc/init.d/zarafa-ws start
    Starting Zarafa WS Traceback (most recent call last):
    File "/usr/src/packages/BUILD/zarafa-7.1.8/ECtools/zarafa-ws/zarafa-ws.py", line 7, in <module>
    File "./zarafa_ws/main.py", line 7, in <module>
    File "/usr/lib64/python2.6/site-packages/daemon/pidlockfile.py", line 33, in <module>
    class PIDLockFile(LinkFileLock, object):
    TypeError: Error when calling the metaclass bases
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  8. #8
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    On github there's an interesting comment about pylockfile:

    Note: In version 0.9 the API changed in two significant ways:

    * It changed from a module defining several classes to a package containing
    several modules, each defining a single class.

    * Where classes had been named SomethingFileLock before the last two words
    have been reversed, so that class is now SomethingLockFile.

    The previous module-level definitions of LinkFileLock, MkdirFileLock and
    SQLiteFileLock will be retained until the 1.0 release.

    Version 0.9
    ===========

    * The lockfile module was reorganized into a package.

    * The names of the three main classes have changed as follows:

    LinkFileLock -> LinkLockFile
    MkdirFileLock -> MkdirLockFile
    SQLiteFileLock -> SQLiteLockFile

    * A PIDLockFile class was added.
    Last edited by zmi1; 27-11-2013 at 08:19 AM.
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  9. #9
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169
    Ideas? Solutions?
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

  10. #10
    Senior Member zmi1's Avatar
    Join Date
    Apr 2009
    Location
    Korneuburg, Austria
    Posts
    169

    How to solve this on SLES?

    Still the same shit here. We NEED to test ZWS, but calling zarafa-ws does this:

    This is with default python installed, all are from SLES11-SP3:
    When we add the official python repo and do an upgrade it still doesn't work:
    It says this:
    Anyone got zarafa-wa running on SLES 11 SP3?
    Michael Monnerie (aka zmi)
    Professional Zarafa Hosting at http://www.proteger.at/produkte/moremail.html

Page 1 of 9 123 ... LastLast

Similar Threads

  1. WebApp 1.4 Feedback
    By Dominique in forum WebApp
    Replies: 46
    Last Post: 11-06-2014, 11:59 AM
  2. Z-Push 2.0 alpha2 released
    By Sebastian in forum Z-Push when using Kopano/Zarafa
    Replies: 23
    Last Post: 05-09-2011, 08:15 PM
  3. 6.20 RC2 Feedback
    By luis in forum Beta Feedback Archives
    Replies: 1
    Last Post: 07-01-2009, 09:35 AM
  4. 6.0 RC3 Feedback
    By aw_AFRISO in forum Beta Feedback Archives
    Replies: 4
    Last Post: 22-02-2008, 08:10 AM
  5. 6.0 RC2 Feedback
    By luis in forum Beta Feedback Archives
    Replies: 5
    Last Post: 21-02-2008, 03:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •