Results 1 to 6 of 6

Thread: Samba4 AD/Zarafa-schema breaks when integrating

  1. #1
    Member
    Join Date
    Dec 2009
    Location
    Germany/Hannover
    Posts
    46

    Samba4 AD/Zarafa-schema breaks when integrating

    Hallo!

    I am testing the integration of the Zarafa-AD-Schema into my Samba 4 DC. Unfortunately the process breaks. Maybe someone can help. First the error and after that the details:

    This is how I start the process:


    System: information:
    * CentOS 6 (newest packages)
    * zarafa-ads-1.3 from zarafa-community-page
    * Samba 4.0.1 from samba.org self compiled (./configure --enable-old-ctdb; make; make install)
    Samba-Installation Parameters:

    I have searched around if there was an object with the dn: CN=zarafaDynamicGroup-Display,CN=401,CN=DisplaySpecifiers,CN=Configurati on,DC=tali,DC=lab.
    I think I have found the right place and can confirm that this object does not exist:

    My guess is, that the zarafa-ads-integration 1.3 was tested against Samba 4.0 and that there where slight changes to Samba 4.0.1 which break the process. But if I am wrong, I would appreciate some help. :-)

  2. #2
    Member
    Join Date
    May 2009
    Location
    Hamburg, Germany
    Posts
    49
    Hi,

    we use Samba4 on a Debian Sid whith Zarafa.

    In /etc/samba/smb.conf

    # Global parameters
    [global]
    sdb:schema update allowed = yes

    Than:
    /root/zarafa/zarafa_schema_add.sh DC=DOMAIN,DC=DE /root/zarafa/ldfiles -v -H /var/lib/samba/private/sam.ldb -writechanges


    Wait^^

    And install zarafa-ads tool in the Remote Computer, where you have Administration Tools of WIndows installed.



    sorry for my english and I hope, i can help you

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Location
    Göttingen, Germany
    Posts
    23
    Althoug grievis answer contained all the right details I just wanted to add this for clearification:

    I was just talking to my Colleague who wrote the zarafa_schema_add.sh script, who mentioned that most people who report errors forgot the "-writechanges" switch. Since the later modifications rely on the earlier ones you will get the mentioned "[many lines of output without an error message]" at first and then errors without "-writechanges"

    One other thing is that you don't really need the "schema update allowed = yes" in smb.conf when you work directly on the sam.ldb (-H /var/lib/samba/private/sam.ldb instead of i. e. -H ldap://mydc.samdom2.example.private).

    Cheers
    Thomas

  4. #4
    Member
    Join Date
    Jan 2011
    Location
    Liechtenstein
    Posts
    44
    Hi Thomas,

    this is new to me, thanks for the useful info, makes things a little bit less complicated (at least one step less...) ;-)

    Regards
    Peter

  5. #5
    Junior Member
    Join Date
    Jun 2013
    Posts
    1
    Hey guys,
    i have exactly the same problem like grenzlaeufer when using the commmand-line without -writechanges. Everything seems to work fine but until few seconds i get the same message as grenzgaenger.
    Ok, so i tried using the -writechange addition but than i get the following:
    'rror: Bad ldif changetype 'add
    'rror: Bad ldif changetype 'modify
    ERR: (No such object) "objectclass: Cannot add CN=Zarafa-Quota-Override,CN=Schem, parent does not exist!" on DN CN=Zarafa-Quota-Override,CN=Schema,CN=Configuration,DC=DOMAIN,DC=C OM
    Modified 0 records with 1 failures
    Error: ldbmodify reported an error

    (using Ubuntu 12.04 + Zarafa 7.1.4 + Samba4 4.0.6)

  6. #6
    Junior Member
    Join Date
    Sep 2016
    Posts
    1
    Hi everyone, I know this is an old thread, but Google lead me here and I might have a solution:

    This is a typical error when the file is not in unix format (e.g. has CRLF line terminators). This can be checked with:
    And it can be solved with:
    Best regards,
    Michael

Similar Threads

  1. samba4, zarafa 7.1.2 webaccess SSO
    By odiX in forum Administration and Integration
    Replies: 2
    Last Post: 07-03-2013, 02:30 PM
  2. Samba4 AD Zarafa
    By chomes in forum Administration and Integration
    Replies: 4
    Last Post: 07-02-2013, 02:45 PM
  3. Samba4 AD Integration for Zarafa
    By tdeklein in forum Administration and Integration
    Replies: 0
    Last Post: 27-04-2012, 07:00 PM
  4. Samba4 Schema / ADS Plugin
    By Grievi in forum Administration and Integration
    Replies: 2
    Last Post: 02-04-2012, 11:06 AM
  5. Integrating a web application with Zarafa
    By decibel83 in forum PHP Development
    Replies: 1
    Last Post: 09-01-2012, 02:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •