Results 1 to 5 of 5

Thread: xmpp + apache + zarafa webapp setup?

  1. #1
    Junior Member
    Join Date
    Oct 2012
    Posts
    4

    xmpp + apache + zarafa webapp setup?

    Hey all, I'm trying to setup an xmpp server on my zarafa box, it's not going so well. The doc covers the basics but my setup is a little funky, so I can't get it to work:



    Here's my setup. I've got my server with a fqdn of hostname.internal.example.com. But my xmpp address should be jabber.diffexample.com (yep, on a different domain name). I've setup a cname to point to my internal server and that's working fine. Also, my server is not accessible externally on port 80, only ssl port 443. Apache does not listen on port 80, only 443. I've also opened up the jabber port externally, and there's no firewall restriction on the server right now.

    The problem I'm having is with apache. I get a forbidden error when visiting jabber.diffexample.com. The XMPP server and Zarafa are both on the same machine. Here's proxy.conf settings file for apache:

    Here's my webapp apache config file:

    Any ideas on getting this to work? I'm pretty sure the problem is with the apachy proxypass directives but I don't know what to set it to. Nothing I try seems to work.
    Last edited by bitJericho; 04-10-2012 at 10:28 AM.

  2. #2
    Junior Member
    Join Date
    Oct 2012
    Posts
    4
    here's my ejabberd.cfg file:

    Last edited by bitJericho; 04-10-2012 at 10:25 AM.

  3. #3
    Senior Member
    Join Date
    May 2006
    Location
    Delft
    Posts
    1,935
    Looks like the ejabberd config is not fully paste here.
    Can you btw check if the http-bind is also listed and enabled in the module loading section.

    Milo

  4. #4
    Junior Member
    Join Date
    Oct 2012
    Posts
    4
    Ok. So I didn't realize that config file got cut off! Should have, but didn't. Reinstalled, got ejabberd running. I can connect to it using the example.com domain and opening up the port, but proxying still doesn't seem to work. I get forbidden errors, even when using wget from localhost. Here's my port.conf apache file:

    The top of my webapp config file:
    And the output from wget:

    And yeah i'll get around to updating that certificate eventually:P

  5. #5
    Junior Member
    Join Date
    Oct 2012
    Posts
    4
    For some reason my reply was sent to a mod and then has never been approved. So I'll try again

    Yes, it appears my ejabberd config was cut off, didn't realize it. Probably should have, but didn't Ejabberd was still launching fine! Anyway, I fixed that and now I can communicate with ejabberd. However, I still get forbidden errors when visiting my URL that gets proxied. Here's an updated version of my apache config files:


    The idea is I want to be able to use zarafa at hostname.example.com/webapp, and my jabber url be jabber.example[b]2[b].com

    Any idea how to get this properly configured? I'm not sure why I'm getting forbidden errors.

    I've even tried this:

    But then I get an internal server error, so maybe something's not right with my ejabberd config? That file is too long so here's a link to it from pastebin:

    Last edited by bitJericho; 16-10-2012 at 12:30 PM.

Similar Threads

  1. Zarafa WebApp + xmpp plugin timeout
    By vincentvdk in forum WebApp
    Replies: 1
    Last Post: 02-10-2013, 05:37 PM
  2. webapp xmpp with starface voip
    By segro in forum Administration and Integration
    Replies: 3
    Last Post: 21-06-2012, 10:25 AM
  3. XMPP plugin issues
    By zeguigui in forum WebApp
    Replies: 8
    Last Post: 11-06-2012, 05:38 PM
  4. Zarafa/Apache/PHP Problem
    By christof in forum Installation and Configuration Archives
    Replies: 4
    Last Post: 21-10-2009, 11:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •