Results 1 to 5 of 5

Thread: Webapp loads too slowly for the first time

  1. #1
    Junior Member
    Join Date
    Jun 2012
    Posts
    20

    Webapp loads too slowly for the first time

    Dear all
    I just installed webapp for zarafa-7.0.7 on Centos. For the first time when it wants to load, it takes too long to login. After a while the login process finishes and then it will work fine.
    Have you any idea why it is slow for first time of loading? Is it because of caching javascript codes?
    And is there any way to improve its performance? Since zarafa demo works quickly, there should be a way to reduce the loading time.
    Bests,

  2. #2
    Senior Member
    Join Date
    May 2006
    Location
    Delft
    Posts
    1,935
    Hi,

    The first time you login all the javascript need to be downloaded and processed, this takes some time. For the processing of first screen also quite some data need to be retrieved from the server, so performance of server will help in this case.

    The javascript files are cached, but still the main screen has to rendered based on server content.

    Milo

  3. #3
    Junior Member
    Join Date
    Jun 2012
    Posts
    20
    Hi Milo
    Thank you for help.
    It's reasonable. but why the zarafa demo at demo.zarafa.com works quickly even at the first time of login? Is it just because of their powerful servers?
    Thanks again,

  4. #4
    Senior Member
    Join Date
    May 2006
    Location
    Delft
    Posts
    1,935
    I think it's indeed the combination of servers and very small amount of folders and data in the mailbox.

    Milo

  5. #5
    Junior Member
    Join Date
    Jun 2012
    Posts
    20
    Thanks,
    Actually, I have no folder or any other item in my mailbox yet. So, it seems that I should empower my servers.

Similar Threads

  1. Replies: 6
    Last Post: 30-08-2012, 09:33 AM
  2. Apache2 hangs from time to time
    By MyKey0815 in forum WebAccess
    Replies: 6
    Last Post: 22-01-2012, 09:22 AM
  3. webmail slowly
    By thierrymangin in forum Installation, Configuration and Maintenance
    Replies: 6
    Last Post: 04-10-2011, 08:09 AM
  4. Changing Appointment Start Time Changes End Time
    By johannesinmedias in forum WebAccess usage Archives
    Replies: 2
    Last Post: 05-06-2009, 10:56 PM
  5. Appointment time linked to system time?
    By arthur in forum Outlook usage Archives
    Replies: 6
    Last Post: 05-08-2008, 01:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •