Results 1 to 4 of 4

Thread: upgrade problem 7.0.29470 -> 7.0.6.32752

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    2

    [SOLVED] upgrade problem 7.0.29470 -> 7.0.6.32752

    Hi,

    I tried this ...

    1.) Full database backup of 7.0 system (mysqldump -u root -p --single-transaction -p zarafa > /srv/backup/zarafa.sql)
    2.) Restore to a fresh 7.0.6 system (mysql -u root -p zarafa < /srv/backup/zarafa.sql)

    The server won't start anymore.

    Is there anything I can do?

    Andy

    ---- server log ----
    Fri May 4 08:55:33 2012: Start: Creating client update status table
    Fri May 4 08:55:33 2012: 0x00000001e5eb20: SQL Failed: Table 'clientupdatestatus' already exists, Query Size: 518, Query: "CREATE TABLE clientupdatestatus ( `userid` int(11) unsigned NOT NULL, `trackid` int(11) unsigned NOT NULL, `updatetime` DATETIME NOT NULL, `currentversion` varchar(50) binary NOT NULL, `latestversion` varchar(50) binary NOT NULL, `computername` varchar(255) binary NOT NULL, `status` int(11) unsigned NOT NULL, PRIMARY KEY (`userid`), UNIQUE KEY (`trackid`) ) ENGINE=InnoDB CHARACTER SET utf8 COLLATE utf8_general_ci;"
    Fri May 4 08:55:33 2012: Failed: Rollback database
    Fri May 4 08:55:33 2012: Can't update the database: Unable to upgrade zarafa from version 7.0.29470 to 7.0.6.32752
    Fri May 4 08:55:33 2012: Server shutdown complete.
    ---- server log ----

    After some caffeine ... and ... drop table clientupdatestatus
    the server starts again.
    Last edited by bandyt; 04-05-2012 at 09:17 AM. Reason: solved

  2. #2
    Senior Member rxshorty's Avatar
    Join Date
    Dec 2011
    Location
    The Netherlands
    Posts
    134
    Good to hear it works again.
    The way I work is uninstall zarafa and leave the config files.
    After that I install it again, takes about a few minutes and everything runs again.
    Running Zarafa 7.1.5 as private mail server.
    Lindoboom.nl

  3. #3
    Zarafa Support
    Dominique's Avatar
    Join Date
    May 2010
    Location
    The Netherlands
    Posts
    168
    Strange that it already existed, had the zarafa-server perhaps crashed previously with an older version?
    It must have decided the table clientupdatestatus was incomplete.

    Perhaps you can check your mysql dump file what the table definitions were for that table before upgrading.
    Before making a new thread, please make sure that you have searched on our forums and read the Zarafa documentation.

  4. #4
    Junior Member
    Join Date
    May 2012
    Posts
    2
    I backed up database with a running zarafa-server. - My fault.
    So the temporary table is in the backup.

    The server tried to create this table at startup and died.

    May be the table should automatically be dropped during startup.

Similar Threads

  1. [Resolved] z-push-admin broken on zcp-7.0.6-32752-debian-6
    By datenhain in forum Mobile devices
    Replies: 1
    Last Post: 30-03-2012, 06:06 PM
  2. Upgrade: 7.0.X->7.0.X problem
    By Banks in forum Installation and Configuration
    Replies: 0
    Last Post: 11-01-2012, 11:10 AM
  3. [SOLVED] Mapi.so problem after PHP5 upgrade
    By falcon15500 in forum Installation and Configuration Archives
    Replies: 0
    Last Post: 25-02-2010, 11:59 PM
  4. public store problem after upgrade to 6.30.9
    By Socrates in forum Administration and Integration Archives
    Replies: 1
    Last Post: 22-01-2010, 07:52 PM
  5. License-problem after upgrade from 6.20.x to 6.30.2
    By JDOS in forum Migration Archives
    Replies: 2
    Last Post: 17-09-2009, 10:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •