Page 3 of 22 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 219

Thread: SabreDAV backend for Zarafa

  1. #21
    Senior Member
    Join Date
    Mar 2011
    Posts
    346

    Re: SabreDAV backend for Zarafa

    Tested 0.5, but this version doesn't work as expected. Possibly because it isn't possible anymore to set the domain name.

    I get the following php error with sabre-php51 installed (debug.txt doesn't show more than this):
    Because of this error, nothing works anymore. Tested this in the browser and emClient.

  2. #22

    Re: SabreDAV backend for Zarafa

    Looks like I have the same problem here... everything worked fine when I was already authenticated, not for first auth!
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

  3. #23

    Re: SabreDAV backend for Zarafa

    Tested with Chrome, this works... not Firefox?!
    This is a really strange bug this one!!!
    emClient seems to be OK
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

  4. #24
    Senior Member
    Join Date
    Mar 2011
    Posts
    346

    Re: SabreDAV backend for Zarafa

    Tested in in FF 9, Chrome and IE 9. FF and Chrome give the mentioned error, IE doesn't work at all (not even an php error).
    As I said: maybe it is because the domainname of the testserver and the domainname of the login don't match, and you automatically detect and use the second one.
    Is it maybe possible to make this optional, as there will be lots of Zarafa servers the run on a differernt domainname than the login is and there are lots of Multi-tenant installs on which this won't work.

  5. #25

    Re: SabreDAV backend for Zarafa

    This is why I removed the need of setting the domain name. I rely on a zarafa function which gives the full email address. The domain name was need to create the user email address based on his username.

    The problem is this error is triggered before any call to the function generating the email address...

    Did you get the authentication box asking for username and password before the error was triggered? This could be an hint of the problem.
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

  6. #26
    Senior Member
    Join Date
    Mar 2011
    Posts
    346

    Re: SabreDAV backend for Zarafa

    Ok, you know best about the domain name :-)

    And about the error: *OOPS* zarafa-server wasn't running because I reconfigured OpenLDAP for some other testing.
    In the browser it works again, and even better, changing and adding contacts in emClient works as well. Great work!

    In debug.txt, I get a number of corrupted characters like these
    I don't know if this is important or not?

  7. #27

    Re: SabreDAV backend for Zarafa

    I would say this is an error I will not fix in the next release :mrgreen:

    For the debug this is correct, I do not (always) translate zarafa internal ids to a "human readable" string. There is nothing wrong!

    And I am happy that you managed to add and change contacts with emClient.
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

  8. #28
    Senior Member
    Join Date
    Mar 2011
    Posts
    346

    Re: SabreDAV backend for Zarafa

    If the 'corruption' is only that: I can imagine you can spend your time better ;-)

    Today I started some more testing, but I found out that deleting contacts from emClient doesn't work. I don't get an error in emClient or debug.txt, it just reloads the list with contacts and the deleted contact is shown again.
    This is the case for contacts created in Webaccess and emClient.

    Adding or changing contacts in emClient works OK and the changes are shown in Webaccess (and the other way around).

  9. #29

    Re: SabreDAV backend for Zarafa

    Yes, this is a bug!

    In the very first versions of the backend I used entry ids as filenames instead of generated GUIDs... that was making functions to access contacts easy to write. I changed all the procedures to use GUIDs but I forgot the deleteCard!

    I will fix that in the 0.7 release!
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

  10. #30

    Re: SabreDAV backend for Zarafa

    ... release 0.7 is available :mrgreen:

    Thanks to you and other users this is getting fairly usable! There is still some work to do to get a 1.0 version but this is fairly encouraging!
    Zarafa 7.2.4 - Ubuntu 14.04 - Z-Push 2.2.1

Page 3 of 22 FirstFirst 1234513 ... LastLast

Similar Threads

  1. CentOS 5.7, Zarafa 7.0 via yum, Unix user backend
    By cthielen in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 27-10-2011, 03:00 AM
  2. Strange Behaviuor Using OpenLDAP Backend
    By khoward in forum Installation, Configuration and Maintenance
    Replies: 6
    Last Post: 10-08-2011, 12:37 PM
  3. Migration from unix backend to ldap backend
    By unacle in forum Migration Archives
    Replies: 2
    Last Post: 02-02-2010, 09:46 AM
  4. Webaccess with Exchange backend
    By thatha in forum PHP Development Archives
    Replies: 3
    Last Post: 10-02-2009, 10:42 AM
  5. User backend migration
    By ToniVR in forum Installation and Configuration Archives
    Replies: 0
    Last Post: 16-01-2009, 05:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •