Hi,

As fedora PHP maintainer, I'm working on PHP 5.4 and testing most extension compatibility.

mapi extension fails because pval type is no more available.

Patch proposal :

Regards