Results 1 to 4 of 4

Thread: Creating Signatures for 130 Users

  1. #1
    Junior Member
    Join Date
    Dec 2008
    Posts
    2

    Creating Signatures for 130 Users

    Hi there,

    i'm searching for an solution to handle the mail signature of 130 Users.
    Is there a posibillity to set the signature of an user via php mapi.

    Greeting

    Detlev.

  2. #2
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475

    Re: Creating Signatures for 130 Users

    Hi Detlev,

    yes, it's possible to set the signatures in php-mapi, however for the webaccess only. Just take a look how it's done in the webaccess code.

    Greets, Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  3. #3
    Junior Member
    Join Date
    Dec 2008
    Posts
    2

    Re: Creating Signatures for 130 Users

    Hi Manfred,

    thanks for your info.

    I have found some functions in the file signature.js
    function saveSignaturesInSettings()

    But i dont know wheter this is the right function and how to use it in the right usercontext. May I have to login in the user?

    Could you give me some more infos.

    Thank you
    Detlev.

  4. #4
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475

    Re: Creating Signatures for 130 Users

    Hi Detlev,

    sorry, but as I'm not a webaccess core developer, it may be not 100% accurate.

    Signatures together with another webaccess settings are saved in PR_EC_WEBACCESS_SETTINGS property. This property is either in XML format or a serialized php. So, you "just" have to alter the signature part in this property. In order to set it, you will have to login as that particular user. The easiest way to do this, is to login as an admin, open the users' stores, set the property.

    Greets, Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

Similar Threads

  1. [Solved] problem creating users in multicompanie
    By capitainekurck in forum Installation and Configuration Archives
    Replies: 4
    Last Post: 02-01-2011, 01:19 AM
  2. adding non active users trouble creating box
    By ToverLi in forum Installation and Configuration Archives
    Replies: 13
    Last Post: 26-11-2009, 11:55 AM
  3. creating "invisible" users possible?
    By Vogi in forum Administration and Integration Archives
    Replies: 2
    Last Post: 21-03-2009, 11:14 AM
  4. Signatures
    By stephen in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 04-03-2008, 06:59 PM
  5. Users are not showing up and can't creating a group
    By cap3001 in forum Beta Hosted Feedback
    Replies: 1
    Last Post: 21-01-2008, 09:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •