Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Mail being sent several times

  1. #1

    Mail being sent several times

    Hi all,

    We're having a problem with one of our machines. It's running the community edition version 6.40.0 on Debian lenny with postfix and the users are accessing it via the Outlook plugin. Some emails are being sent to the recipient multiple times. I'm aware that there is a fix in version 6.40.2 related to Zarafa-spooler sending messages multiple times but I'm not totally sure if this will fix it. According to the changelog the description is:
    The problem is that the email seems to be sitting in the user's Outbox and being re-sent every few minutes, rather than being moved to Sent Items after successful sending. The message sending is logged in both /var/log/zarafa/spooler.log and /var/log/mail.log. According to the postfix log the total message delay is less than 3s, which doesn't sound like a long delay to trigger the bug mentioned in the changelog. Here's a sample entry for the message in question:
    Has anyone seen anything similar? Is upgrading to 6.40.2 likely to fix the issue, and if not does anyone have any suggestions for other fixes? This has happened a number of times in the past, today the message in question got send to the recipient about 100 times and he was not pleased! I had to manually go into the Outbox and delete the message to stop it being sent again, which isn't really a good workaround, especially for the less tech-savvy end users.

    Thanks in advance for any help.

  2. #2
    Zarafa QA
    Robin's Avatar
    Join Date
    Jul 2009
    Location
    Delft, Netherlands
    Posts
    4,671

    Re: Mail being sent several times

    hello Kitserv,

    Fix: Zarafa-spooler tries to send delayed messages continuously is a fix to prevent the spooler to take up to much memory on mails that are set to be delivered later. This will not fix your issue.

    Your issue: Does the message show up multiple times in the logs?

    Greetings,
    Robin
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://www.zarafa.com/content/documentation
    Zarafa Community webpage: http://community.zarafa.com

  3. #3

    Re: Mail being sent several times

    Hi Robin,

    Thanks for your response. Yes, the message shows up in the Zarafa logs and the Postfix logs each time it's re-sent. Here are some sample snippets:
    As you can see, the log entries for the spooler and postfix match up on the timestamp.

  4. #4
    Zarafa QA
    Robin's Avatar
    Join Date
    Jul 2009
    Location
    Delft, Netherlands
    Posts
    4,671

    Re: Mail being sent several times

    Hello Kitserve,

    It looks like that your client really sends the message this may times. Anything special to you outlook? (other plugins)

    Greetings,
    Robin
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://www.zarafa.com/content/documentation
    Zarafa Community webpage: http://community.zarafa.com

  5. #5

    Re: Mail being sent several times

    The user doesn't have any plugins, the only thing I'm aware of that they have installed that interacts with Outlook is Zone Alarm Extreme Security. That said, apparently Outlook crashed on their machine earlier today due to a lack of memory, so perhaps this is part of a wider problem with Outlook and not specifically Zarafa related. I am a bit concerned that it has happened several times in the past though.

    For the time being I think we will have to leave this unless there's something else you think I should look at, I'll ask the user to let me know if it happens again.

    Thank you for your help

  6. #6

    Re: Mail being sent several times

    I've just had a report of a very similar problem from a user at another (independent) site. This site is running a licenced copy of Zarafa Standard 6.40.2 on CentOS 5 x86, again with postfix. The user is using the Outlook plugin via an Apache SSL proxy over the internet with Outlook 2007 (x86 on Windows XP). She has Microsoft Security Essentials and Microsoft Office Business Contact Manager installed, as far as I know they are the only programs that interact with Outlook.

    Just to clarify, the other user that I originally started this thread on is using Outlook 2007 on WinXP 32-bit too, but has different antivirus/antispam as mentioned in my last post. She is also connecting via an Apache SSL proxy, but over a LAN connection.

    In both cases the re-sent message appears multiple times in the Zarafa spooler logs and the postfix logs. Both users were previously using Outlook 2007 with Exchange, and they claim that this problem did not occur until the switch to Zarafa. Obviously it's very difficult to back that statement up 100%, but it's definitely a possibility that the problem is being caused by the Zarafa Outlook plugin in some way.

    Both users are using Zarafa Cached mode. I am going to suggest that they try increasing Outlook's server timeout settings as per , is it worth opening a ticket on the portal too for the users with a paid licence? Any other suggestions for things to try?

    Thanks in advance.

  7. #7
    Zarafa QA
    Robin's Avatar
    Join Date
    Jul 2009
    Location
    Delft, Netherlands
    Posts
    4,671

    Re: Mail being sent several times

    Hello Kitserve,

    What happens when the delete mails? Then it could be a issue with the notifications.

    Greetings,
    Robin
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://www.zarafa.com/content/documentation
    Zarafa Community webpage: http://community.zarafa.com

  8. #8

    Re: Mail being sent several times

    I got the user to try deleting a couple of emails, it worked as normal.

  9. #9

    Re: Mail being sent several times

    The problem seems to be getting worse, I've been corresponding with the user via email throughout the day and messages are getting re-sent from the user to my account. Previously the re-sending problem was only occurring when sending to external users. The user has been using Z-push/ActiveSync on an Android phone due to the problems with Outlook, and that is apparently working normally, so it looks like a problem with the Outlook plugin.

  10. #10

    Re: Mail being sent several times

    UPDATE: Increasing the Server Connection timeout in Zarafa Outlook settings mitigates the problem somewhat but does not solve it. The server in question is set up with an Apache SSL proxy for the users to access. The Zarafa support guys have suggested trying a direct connection to Zarafa on port 237 instead, which we are now trying. So far the problem doesn't seem to have come back, so perhaps it is caused by the use of an Apache proxy.

Page 1 of 2 12 LastLast

Similar Threads

  1. Long loading times in webaccess
    By sverre in forum WebAccess
    Replies: 23
    Last Post: 22-02-2012, 01:07 PM
  2. zarafa-offline.exe is running up to four times
    By zarafatk in forum Outlook client
    Replies: 1
    Last Post: 07-11-2011, 08:16 AM
  3. Calendar Items 3 times
    By lines in forum Installation, Configuration and Maintenance
    Replies: 2
    Last Post: 10-07-2011, 03:24 PM
  4. times in SugarCRM tasks
    By WalterH in forum Z-Merge Development Archives
    Replies: 1
    Last Post: 25-11-2010, 08:11 PM
  5. Mail being sent multiple times
    By yanqui in forum Outlook usage Archives
    Replies: 3
    Last Post: 05-09-2009, 08:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •