Results 1 to 7 of 7

Thread: Zarafa server 6.30.9 died with sigsegv on fedora 12

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    14

    Zarafa server 6.30.9 died with sigsegv on fedora 12

    Hello,

    I've installed Zarafa version 6.30.9 on a fedora 12 64bit linux system.
    After trying to create a user (plugin db) with the command
    I get a "Unable to create user, unknown error (0x80040115)" and the zarafa server died
    with the following sigsegv:
    Can someone give me a hint?

    Greetings,
    Bjoern

  2. #2
    Zarafa Developer

    Join Date
    May 2006
    Location
    Delft
    Posts
    636

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    Did you build from source? And if yes, did you change the source?

    If you did build from source, you can use gdb to run the server in, and make it crash to get more details.

    Do you have a special script in the userscripts/createuser.d dir?
    If it isn't reproducable, it's not a bug.
    If it is reproducable, it's meant to be that way.

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    14

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    Hi John,

    thank you for your reply.

    Yes, I build zarafa from source, but with a spec-file from Robert Scheck with two patches for configure.ac/Makefiles.
    (The spec file from Robert is originally for zarafa-6.30.4).

    I'm not very familiar with gdb. If I start debugging with gdb, I always get a SIGPIPE - Broken Pipe. So here is the in-/output:
    This is all Greek to me!

    No.

    Thank you!

    Greetings,
    Bjoern

  4. #4
    Zarafa Developer

    Join Date
    May 2006
    Location
    Delft
    Posts
    636

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    place this in you $HOME/.gdbinit and try again:
    If it isn't reproducable, it's not a bug.
    If it is reproducable, it's meant to be that way.

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    14

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    Hi John,

    thanks for your fast reply.

    Here is the new gdb-session:
    Greetings,
    Bjoern

  6. #6
    Junior Member
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    14

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    Hello,

    the problem with the sigsegv seems to be a problem from the zarafa-6.30.4 spec file, which
    I used to build 6.30.9 and 6.40.0 RC1.
    When building the 6.40.0 RC1 from "plain" source the zarafa-admin -c command works well.
    I think, building 6.30.9 from source, will also work.

    Sorry!

    Greetings,
    Bjoern

  7. #7
    Senior Member
    Join Date
    Feb 2008
    Location
    Leonberg, Germany
    Posts
    273

    Re: Zarafa server 6.30.9 died with sigsegv on fedora 12

    No, it is not. It is only lazy coding and ignorance of long-time gcc/glibc features like the fortify source in this case of Zarafa.

    Right now, Zarafa is already part of Fedora (in updates-testing), have a look to how to install the packages. Note that you right now need "yum install --enablerepo=updates-testing" once it hits the regular stable updates repository.
    I install, configure, customize, integrate and maintain Zarafa setups in different environments since 2007. If you want my full attention, please send me a private message and ask for paid support.

Similar Threads

  1. zarafa-server dies with SIGSEGV
    By adminia in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 10-10-2011, 10:41 AM
  2. Zarafa Server 6.40.5 on Ubuntu 8.04 crashes with SIGSEGV(6)
    By blackjack97 in forum Installation and Configuration Archives
    Replies: 3
    Last Post: 03-03-2011, 08:17 AM
  3. CentOS 5.4[CAUGHT SIGSEGV (11)]Zarafa-server
    By odewitt in forum Installation and Configuration Archives
    Replies: 3
    Last Post: 14-05-2010, 12:53 PM
  4. zarafa-gateway process died
    By stephanhohn in forum Installation and Configuration Archives
    Replies: 1
    Last Post: 27-08-2009, 04:07 PM
  5. Command died with signal 11
    By arthur in forum Outlook usage Archives
    Replies: 2
    Last Post: 21-11-2008, 08:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •