Results 1 to 2 of 2

Thread: How to prepare abdebug / trace enabled Zarafa build 6.20.1

  1. #1
    Senior Member
    Join Date
    Nov 2008
    Location
    Hilden, close to Duesseldorf, NRW, Germany, Europe, Earth...
    Posts
    1,070

    How to prepare abdebug / trace enabled Zarafa build 6.20.1

    Good Morning,
    I've tried to build a debug version with trace enabled. Unfortunately this looks harder than it should...

    At first I needed to correct the file m4l.debug.h
    Afterwards I found that during make install the libraries have sometimes the extension T without being build with this. I have no better idea to fix this than to rename the linked file to the one with extension T. These files have been effected:
    ./inetmapi/.libs/libinetmapi.so.1.0.0T
    ./provider/client/.libs/libzarafaclient.so.1.0.0T
    ./libicalmapi/.libs/libicalmapi.so.1.0.0T
    ./php-ext/.libs/mapi.so.0.0.0T

    After having everything from the debug installed I started the server with -F option to have all stderr output of soap and mapi calls on screen but just got the INTERNAL logging returned.

    Somebody having an idea what I'm doing wrong? I try to identify all functions by this that have to be changed in case I write fields in UTF-8 instead of Windows-125x encoding to the database. To keep compatibility I would like to return them in Windows-125x encoding in case the client requests the properties without the MAPI_UNICODE flag.

    With best regards

    Andreas
    Using Zarafa 7.2.5-29, Z-Push 2.3.4 with GZip and soon again SMS Support.

  2. #2
    Senior Member
    Join Date
    Nov 2008
    Location
    Hilden, close to Duesseldorf, NRW, Germany, Europe, Earth...
    Posts
    1,070

    Re: How to prepare abdebug / trace enabled Zarafa build 6.20.1

    Fixed the T lib install issue by removing it in ltmain.sh line 5959 and run configure again...
    Using Zarafa 7.2.5-29, Z-Push 2.3.4 with GZip and soon again SMS Support.

Similar Threads

  1. [Solved] "IMAP not enabled for user .. "
    By icrni in forum Installation, Configuration and Maintenance
    Replies: 4
    Last Post: 23-08-2011, 12:54 PM
  2. Error when build zarafa
    By leonardoc in forum Installation and Configuration Archives
    Replies: 0
    Last Post: 03-03-2011, 07:26 PM
  3. Mail enabled public folder
    By pcadmin in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 18-06-2010, 08:10 AM
  4. zarafa 6.20 build 12391 , unix plugin no group members
    By thctlo in forum Installation and Configuration Archives
    Replies: 1
    Last Post: 05-11-2008, 05:01 PM
  5. Default enabled reminder 30 minutes
    By prosolit in forum WebAccess usage Archives
    Replies: 1
    Last Post: 28-04-2008, 10:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •