Hi,

after migrating a ZCP 7.1.14 installation to ZCP 7.2.4 we can not use the LDAP group listed in the addressbook as recipient. For some other reason, we could not exactly follow the ldap guide described in but maybe someone in the forum is able to tell me what is wrong in out setup.

Here are the ldap_group_* parameters from the ldap.cfg:

ldap_groupmembers_attribute = memberUid
ldap_groupmembers_attribute_type = text
ldap_groupmembers_relation_attribute = uidNumber
ldap_groupname_attribute = cn
ldap_group_search_filter = (objectClass=zarafa-group)
ldap_group_security_attribute_type = boolean
ldap_group_security_attribute = zarafaSecurityGroup
ldap_group_type_attribute_value = zarafa-group
ldap_group_unique_attribute = gidNumber
ldap_group_unique_attribute_type = text

This is one of the groups in OpenLDAP:

cn=Testgruppe,ou=Group,o=icp-ing,c=de
objectClass: top
objectClass: posixGroup
objectClass: zarafa-group
cn: Testgruppe
gidNumber: 5020
memberUid: schneider
memberUid: schulz

Server and Spooler are both running in log level 6, and while there is no entry in server.log, spooler.log just contains

Sun May 14 16:25:17 2017: [debug ] [ 3200] /usr/sbin/zarafa-spooler zarafa-spooler --send-message-entryid 000000009E4023EEAA694ACCAF31018FD45A8E2C0100000005 0000003ABB390380CF46579727891692BC4A7500000000 --send-username-enc 736368756C7A --log-fd 4 --config /etc/zarafa/spooler.cfg --host file:///var/run/zarafad/server.sock --foreground localhost --port 25 --do-sentmail NULL
Sun May 14 16:25:17 2017: [info ] [ 2524] Spooler process started on pid 3200
Sun May 14 16:25:17 2017: [debug ] [ 3200] StatsClient binding socket
Sun May 14 16:25:17 2017: [debug ] [ 3200] StatsClient bound socket to /tmp/.575e5c683874eb21.sock
Sun May 14 16:25:17 2017: [debug ] [ 3200] PYTHONPATH = /usr/share/zarafa-spooler/python
Sun May 14 16:25:18 2017: [info ] [ 3200] * Loading plugins started
Sun May 14 16:25:18 2017: [info ] [ 3200] ** Checking plugins in /var/lib/zarafa/spooler/plugins
Sun May 14 16:25:18 2017: [info ] [ 3200] * Loading plugins done
Sun May 14 16:25:18 2017: [debug ] [ 3200] Sending e-mail for user schulz, subject: 'test', size: 4301
Sun May 14 16:25:18 2017: [info ] [ 3200] * PreSending processing started
Sun May 14 16:25:18 2017: [info ] [ 3200] * PreSending processing done
Sun May 14 16:25:18 2017: [debug ] [ 3200] Sending message with Message-ID:
Sun May 14 16:25:18 2017: [warning] [ 3200] E-mail for user schulz could not be sent, notifying user: cancel message (40580)

And the notification contains the following message:

Unfortunately, I was unable to deliver your mail.
The error given was:

No recipients in e-mail

You may need to contact your e-mail administrator to solve this problem.
---------------------------------------------------------

Why is Zarafa not able to get the users of the group?

Thanks for any hint or suggestions,

Stefan