Results 1 to 6 of 6

Thread: S/MIME encrypted messages sent by WebApp can't be decrypted in the SENT folder

  1. #1
    Junior Member
    Join Date
    May 2015
    Location
    Germany
    Posts
    10

    S/MIME encrypted messages sent by WebApp can't be decrypted in the SENT folder

    Hi forum,

    today I discovered an issue with encrypting emails.

    S/MIME encrypted messages I send with WebApp can't be re-opened in the SENT FOLDER of WebApp. The error message reads: "Unable to decrypt this message. Certificate does not match."

    The problem is only sender-side (only with me and in WebApp), the recipients are able to decrypt the messages without problems.

    My S/MIME certificate is correctly installed, in S/MIME settings of WebApp I can see my private and public keys. I have NO problem to decrypt messages that have been encrypted by anyone else and sent TO ME.

    In Outlook, by the way, with Mapi connection everything works fine, I can read all my S/MIME emails in the sent folder of Outlook. Of course only those sent by Outlook. Synchronized messages sent by WebApp can't be decryted in Outlook either.

    Any idea how to fix?


    Thanks
    Alf

    Debian 8
    Kopano WebApp: 3.3.0.622-440.1
    Zarafa Core: 7.2.5-109
    S/MIME Plugin: 2.2.0.130

  2. #2
    Junior Member
    Join Date
    May 2015
    Location
    Germany
    Posts
    10
    Still no solution, but I found a workaround by sending a copy CC or BC to myself which makes the emails readable in the Sent folder.

    Without this trick WebApp or rather the S/MIME plugin seem to encrypt only with the recipient's key and not with both recipient AND sender.

    Can anyone confirm this behavior on your machine? Maybe it's a bug.

  3. #3
    Hi Alf,

    With the latest (kopano s/mime) master this is possible.
    Regards,

    Martyn

  4. #4
    Junior Member
    Join Date
    May 2015
    Location
    Germany
    Posts
    10
    I can confirm it's is working now: You can decrypt your sent messages in WebApp. Great!

    Unfortunately this new plugin (kopano-webapp-plugin-smime_2.2.0.140-75.1_all.deb) has inherited a problem of previous versions: Incoming S/MIME messages are flagged with "Certificate has been revoked" if they are signed with a certificate issued by an own Root CA. This error message shows up even if the Root CA's certificate is correctly installed on /etc/ssl/certs.

    Even more crucial is: You can't import and use a private PKCS#12 certificate to WebApp which is issued by an own Root CA. Same error message: "Certificate has been revoked".

    I guess it's a bug. The last version that does NOT show this behaviour and work properly is kopano-webapp-plugin-smime_2.1.2.79-61.1_all.deb.
    Last edited by alfschauer; 18-05-2017 at 09:51 PM.

  5. #5
    Hi Alfschauer,

    Please have a look at https://jira.kopano.io/browse/KSP-128
    Regards,

    Martyn

  6. #6
    Junior Member
    Join Date
    May 2015
    Location
    Germany
    Posts
    10
    Martyn, this link doesn't seem to work: "This issue can't be viewed"...

    screenshot.png

Similar Threads

  1. Issue: SMIME singed or encrypted messages from BlackBerry PRIV will be scrubbed
    By marcello.ceschia in forum Z-Push when using other backends
    Replies: 0
    Last Post: 29-07-2016, 11:19 AM
  2. Replies: 4
    Last Post: 12-03-2016, 08:12 AM
  3. S/MIME in Zarafa WebApp
    By virusmoere in forum WebApp
    Replies: 7
    Last Post: 10-03-2015, 09:27 AM
  4. GPG/MIME encrypted mails
    By robs in forum Outlook client
    Replies: 0
    Last Post: 30-06-2011, 01:58 PM
  5. Messages in MIME format
    By quinox in forum Administration and Integration Archives
    Replies: 0
    Last Post: 20-10-2009, 02:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •