Results 1 to 4 of 4

Thread: Bug with punctuation marks when text direction from right to left

  1. #1

    Bug with punctuation marks when text direction from right to left

    Hi,
    we are using zarafa 7.2.6.10-3.1 with zarafa-webapp 2.2.1.43-199.1 on UCS 4.1.

    We are communicating with customers from israel. The e-mail is written in English and the text is shown left-aligned. But when answering those e-mails, the text direction is from right to left or right-aligned. This is unusual, but no problem.

    But when you are writing a punctuation mark, e.g. [,] or [.], those are shown at the left beginning of the line and not right behind the last entered word. When the text is continued in the same line, those punctuations are placed where the belong to. When you enter a line break, usually done at the end of a sentence, the punctuation remains at the left beginning of the line.

    I guess this is a bug.

    How do I fix this?

    regards,
    Peter
    regards passt

    Zarafa 7.2.3-657
    OS: Univention UCS 4.1-2
    MTA: Postfix 2.9.x
    Database: MySQL 5.5.X
    Clients: Webapp 2.2.1.43-199.1, Outlook 2007 - 2016, Thunderbird, ...
    Mobile: Z-Push 2.2.9

  2. #2
    Hi Peter,

    This is indeed unusual and I couldn't reproduce this on 2.2.0 or later. Could you check in the html if the dir style is added? Is RTL button enabled in your editor?
    Not your issue, but I actually made a ticket that we shouldn't remove the direction style from the body:

    Unfortunately this is how it works if you use RTL and write in e.g. English.
    Try this for example:
    Regards,

    Martyn

  3. #3
    Yes, dir style is used many times in the html source of the e-mail. The topmost two are 'rtl' and the others are 'ltr'.
    No, both the RTL or LTR buttons aren't enabled.

    "Unfortunately this is how it works..."
    Is it meant as a bug in the editor? Or is it the RFC definition of how to use rtl or ltr?

    Peter

    P.S.: I traced back this e-mail conversation up to when it started. It is from November already and suprisingly when I reply to those first e-mails the text direction isn't changed to rtl. It might be that the use of different e-mail editors on any side of sender and recipient, results in this chaos. Maybe it's one broken e-mail only...?
    regards passt

    Zarafa 7.2.3-657
    OS: Univention UCS 4.1-2
    MTA: Postfix 2.9.x
    Database: MySQL 5.5.X
    Clients: Webapp 2.2.1.43-199.1, Outlook 2007 - 2016, Thunderbird, ...
    Mobile: Z-Push 2.2.9

  4. #4
    All the different editors I've used behave this way (This does not make the current behavior correct).

    TBH, I'm not familiar with the RTL RFC, so If you have more info regarding this issue feel free to share.

    If you could reproduce tis with a new email let me know!
    Regards,

    Martyn

Similar Threads

  1. (Outlook) Sync only in one direction possible
    By micholee in forum Z-Push when using Kopano/Zarafa
    Replies: 11
    Last Post: 13-02-2016, 12:27 PM
  2. Replies: 1
    Last Post: 03-07-2015, 03:18 PM
  3. Background on direction and Outlook
    By helmuth in forum Outlook client
    Replies: 12
    Last Post: 11-02-2015, 07:56 PM
  4. Replies: 1
    Last Post: 23-10-2012, 08:13 AM
  5. [Solved] iPhone shows "???" marks in subject when sync
    By freexy in forum Z-Push when using Kopano/Zarafa
    Replies: 6
    Last Post: 10-09-2011, 09:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •