Results 1 to 3 of 3

Thread: Kopano upgrade from 8.1 to 8.2 multiple conflicts

  1. #1
    Senior Member
    Join Date
    Jul 2010
    Posts
    431

    Kopano upgrade from 8.1 to 8.2 multiple conflicts

    This doesn't look good, same with yum localinstall *.rpm, anyone?...

    rpm -Uvh *.rpm
    warning: gperftools-2.5-34.4.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID ec07c591: NOKEY
    Preparing... ################################# [100%]
    file /usr/lib64/libjansson.so.4 from install of libjansson4-2.7-19.2.x86_64 conflicts with file from package jansson-2.4-6.el7.x86_64
    file /usr/bin/soapcpp2 from install of gsoap-kopano-devel-2.8.43-1.2.x86_64 conflicts with file from package gsoap-kopano-2_8_22-devel-2.8.22-1.1.x86_64
    file /usr/bin/wsdl2h from install of gsoap-kopano-devel-2.8.43-1.2.x86_64 conflicts with file from package gsoap-kopano-2_8_22-devel-2.8.22-1.1.x86_64
    file /usr/include/stdsoap2.h from install of gsoap-kopano-devel-2.8.43-1.2.x86_64 conflicts with file from package gsoap-kopano-2_8_22-devel-2.8.22-1.1.x86_64
    .........................
    .........................

    The list goes on for ages and is too big to post here but mostly a few packages are responsible gsoap-kopano-devel-2.8.43-1.2.x86_64 is the main one.

  2. #2
    Member
    Join Date
    Dec 2010
    Location
    Wr. Neustadt, Austria
    Posts
    51
    try: zypper up *.rpm
    or better install from repositories.
    Regards

    Walter

  3. #3
    Senior Member
    Join Date
    Jul 2010
    Posts
    431
    At the time there was a question about repositories as I have multiple versions but that has been resolved. Kopano have said there is an issue upgrading but removing all the devel and debug packages as they are not needed for normal operation got rid of 90% of the problems. I still had to --force libjansson as it was conflicting with the stock CentOS7 installation. It's all working now though.

Similar Threads

  1. Replies: 16
    Last Post: 31-10-2016, 12:30 PM
  2. Upgrade to Kopano: missing kopano-licensed?
    By RobH in forum Installation, Configuration and Maintenance
    Replies: 7
    Last Post: 26-10-2016, 07:14 AM
  3. Kopano Upgrade script
    By RobH in forum Installation, Configuration and Maintenance
    Replies: 3
    Last Post: 07-09-2016, 07:38 AM
  4. Conflicts with 7.2 / Debian Wheezy
    By peterbeck in forum Installation, Configuration and Maintenance
    Replies: 0
    Last Post: 08-04-2015, 03:04 PM
  5. Conflicts in calendar since 7.0.5
    By Jeanmichel in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 17-04-2012, 07:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •