Results 1 to 4 of 4

Thread: S3 attachment storage not working?

  1. #1
    Junior Member
    Join Date
    Jun 2014
    Posts
    5

    S3 attachment storage not working?

    I tried the s3 attachmant sorage but without success. In my opinion I configured it correctly but server.log says:


    Sun Feb 26 16:14:48 2017: [debug ] Response completed: OK.
    Sun Feb 26 16:14:48 2017: [debug ] Result of the save attachment: OK
    Sun Feb 26 16:14:48 2017: [error ] Unable to write attachment data to S3, key: /19629
    Sun Feb 26 16:14:48 2017: [debug ] Rollback transaction
    Sun Feb 26 16:14:48 2017: [debug ] Delete marked attachment: /19629
    Sun Feb 26 16:14:48 2017: [debug ] Received the response properties, content length: 0.
    Sun Feb 26 16:14:48 2017: [debug ] Response completed: OK.
    Sun Feb 26 16:14:48 2017: [debug ] Result of the delete marked attachment: OK


    System is running CentOS 7 and Zarafa was installed from rpm:

    [[email protected] ~]$ rpm -qa | grep ^zarafa
    zarafa-common-7.2.4.29-99.1.x86_64
    zarafa-backup-plus-7.2.4.29-99.1.x86_64
    zarafa-spooler-7.2.4.29-99.1.x86_64
    zarafa-search-plus-7.2.4.29-99.1.x86_64
    zarafa-webapp-lang-2.2.1.43-199.1.noarch
    zarafa-bash-completion-7.2.4.29-99.1.noarch
    zarafa-lang-7.2.4.29-99.1.x86_64
    zarafa-client-7.2.4.29-99.1.x86_64
    zarafa-utils-7.2.4.29-99.1.x86_64
    zarafa-gateway-7.2.4.29-99.1.x86_64
    zarafa-contacts-7.2.4.29-99.1.x86_64
    zarafa-dagent-7.2.4.29-99.1.x86_64
    zarafa-server-packages-7.2.4.29-99.1.x86_64
    zarafa-devel-7.2.4.29-99.1.x86_64
    zarafa-compat-7.2.4.29-99.1.x86_64
    zarafa-webapp-2.2.1.43-199.1.noarch
    zarafa-server-7.2.4.29-99.1.x86_64
    zarafa-ical-7.2.4.29-99.1.x86_64
    zarafa-monitor-7.2.4.29-99.1.x86_64
    zarafa-presence-7.2.4.29-99.1.x86_64
    Last edited by ukiewel; 26-02-2017 at 06:14 PM.

  2. #2
    Senior Member
    Join Date
    Nov 2012
    Location
    Minneapolis MN, USA
    Posts
    106
    I know in 7.2.4 you couldn't use any region as the open source libs3 library didn't support the correct authentication methods. This has been fixed in Kopano 8.2 although I haven't tested it. Don't know if these changes made it too 7.2.5.



    There is also an s3 command line program that comes with libs3 simply called s3, you can use this to determine if things are working outside of zarafa.
    David
    Last edited by deisenlord; 01-03-2017 at 11:37 PM.

  3. #3
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    If you're evaluating for new version I would anyway suggest to take a look at Kopano, there it should indeed work as expected.

    There was one recent change in 7.2.5 related to S3 (KC-64), but I also have the faint memory that s3 did not really work out for rhel systems and is therefore deactivated on those system (but I cannot find a mention of this, so I might be wrong).

    EDIT: deactivating it was only temporary, through KC-64 it is actually active again, but the library is loaded differently.
    Last edited by fbartels; 02-03-2017 at 08:55 AM.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  4. #4
    Junior Member
    Join Date
    Jun 2014
    Posts
    5
    Thanks for the hint. I moved to Kopano and I can confirm, S3 attachment store works as expected.

    I don't know if it is a supported way but I changes the attachment store from file to S3 and uploaded all files from the attachment directory to one single S3 folder. It works for me.

Similar Threads

  1. Z-Push not working with iPhone, working in Browser
    By Dominic Pratt in forum Z-Push when using other backends
    Replies: 5
    Last Post: 04-02-2016, 06:19 PM
  2. Z-Push not working with iPhone, working in Browser
    By Dominic Pratt in forum Installation and Configuration
    Replies: 3
    Last Post: 04-02-2016, 02:01 PM
  3. find attachment in attachment folder
    By wige in forum Installation, Configuration and Maintenance
    Replies: 2
    Last Post: 27-03-2013, 02:52 PM
  4. Replies: 5
    Last Post: 08-05-2011, 10:59 AM
  5. Removing email attachment files in attachment store
    By marktiller in forum Administration and Integration Archives
    Replies: 3
    Last Post: 18-10-2010, 07:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •