Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Contacts are added, removed and added again ...

  1. #11
    Junior Member
    Join Date
    Feb 2017
    Posts
    11
    Hi manfred,

    yes that was the complete output. Every sync, same output.
    I can't answer the question why it removes the account state.
    For my tests i sync manually on my Mobile under "Einstellungen, Konten, Exchange, Jetzt synchronisieren" (could be in English "Settings, Accounts, Exchange, sync now" or similar)
    The Settings for the Exchange Account on my mobile are default. Except no ssl (for the time of testing) and deactivated sync for E-Mail and calender but activated for the contacts.

    er23

  2. #12
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,471
    Hi er23,

    does your phone have a setting like "Sync schedule"? If yes, what is its setting?

    It might be that for manual sync it suppose to do a full resync.

    In the first post you mentioned that contacts created on android aren't synced to the server. Do you mean existing contacts or contacts created after setting up the account?

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  3. #13
    Junior Member
    Join Date
    Feb 2017
    Posts
    11
    Changed the language on my phone to english.
    Under "settings, account, exchange, account settings, [myaccount], sync frequency" the setting is "Automatic (push)"
    Other possible options are: never or a few different time settings.

    to my first porst: I added the contact after setting up the account. The next sync deletes it from the phone.
    Didn't try with an existing contact before setting up the account.

    Tested now:
    Added contact on phone - waited for automatic sync a few seconds - contact was deleted from the phone

  4. #14
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,471
    Hi er23,

    could you also post the WBXML log for adding a contact? Did this contact appear on the server?

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  5. #15
    Junior Member
    Join Date
    Feb 2017
    Posts
    11
    Hi manfred,

    the contact does not appear on the server.

    Contacts created on the phone are removed from the phone with the very first sync.
    Contacts which are on the Server are added with the first sync, removed with the second sync... added...removed...

    WBXML log after adding a contact on the phone:
    Code:
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] -------- Start
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] cmd='FolderSync' devType='googleNexus' devId='android1487363077942' getUser='test' from='192.168.5.170' version='2.3.4+0' method='POST'
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] Used timezone 'Europe/Berlin'
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] Request::ProcessHeaders() ASVersion: 14.0
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] ZPush::CommandNeedsAuthentication(9): true
    24/02/2017 18:39:36 [ 8191] [DEBUG] [test] BackendCardDAV->Logon(): User 'test' is authenticated on 'http://localhost:80/nextcloud/remote.php/dav/addressbooks/users/test/contacts/'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] BackendCardDAV::discoverAddressbooks() Found addressbook 'http://localhost:80/nextcloud/remote.php/dav/addressbooks/users/test/contacts/'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] FileStateMachine->GetState() read '2842' bytes from file: '/var/lib/z-push/2/4/android1487363077942-devicedata'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ASDevice data loaded for user: 'test'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] TopCollector(): Initialized mutexid Resource id #19 and memid Resource id #20.
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] TopCollector initialised with IPC provider 'IpcSharedMemoryProvider' with type '20'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] LoopDetection(): Initialized mutexid Resource id #23 and memid Resource id #24.
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] LoopDetection initialised with IPC provider 'IpcSharedMemoryProvider' with type '1337'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ZPush::HierarchyCommand(9): true
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ZPush::CommandNeedsPlainInput(9): false
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] I  <FolderHierarchy:FolderSync>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] I   <FolderHierarchy:SyncKey>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] I    {6d16c991-98a7-4591-9778-32c88fd02263}1
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] I   </FolderHierarchy:SyncKey>
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] StateManager->loadHierarchyCache(): 'android1487363077942-6d16c991-98a7-4591-9778-32c88fd02263-hc-1'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] FileStateMachine->GetState() read '244' bytes from file: '/var/lib/z-push/2/4/android1487363077942-6d16c991-98a7-4591-9778-32c88fd02263-hc-1'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] FileStateMachine->GetState() read '95' bytes from file: '/var/lib/z-push/2/4/android1487363077942-6d16c991-98a7-4591-9778-32c88fd02263-1'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] FileStateMachine->GetState() read '372' bytes from file: '/var/lib/z-push/2/4/android1487363077942-6d16c991-98a7-4591-9778-32c88fd02263-fd'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] SyncParameters->UseCPO('DEFAULT')
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ASDevice->GetHierarchyCache(): HierarchyCache is up - Cached objects: 1
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] I  </FolderHierarchy:FolderSync>
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] LoopDetection->ProcessLoopDetectionAddStatus: 'hierarchy' with status 1
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] WBXMLEncoder->startWBXML() type: vnd.ms-sync.wbxml
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] Initializing folder diff engine
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ExportChangesDiff->InitializeExporter(): Initializing folder diff engine
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] BackendCardDAV::GetFolderList()
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] BackendCardDAV::StatFolder('contacts')
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] BackendCardDAV::GetFolder('contacts')
    24/02/2017 18:39:37 [ 8191] [ INFO] [test] ExportChangesDiff->InitializeExporter(): Found '0' changes for 'hierarchy'
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O  <FolderHierarchy:FolderSync>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   <FolderHierarchy:Status>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   1
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   </FolderHierarchy:Status>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   <FolderHierarchy:SyncKey>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   {6d16c991-98a7-4591-9778-32c88fd02263}1
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   </FolderHierarchy:SyncKey>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   <FolderHierarchy:Changes>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O    <FolderHierarchy:Count>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O    0
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O    </FolderHierarchy:Count>
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O   </FolderHierarchy:Changes>
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] DeviceManager->CheckFolderData() checking integrity of hierarchy cache with synchronized folders
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] ASDevice->GetHierarchyCache(): HierarchyCache is up - Cached objects: 1
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] O  </FolderHierarchy:FolderSync>
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] WBXMLEncoder->endTag() WBXML output completed
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] WBXML-OUT: AwFqAAAHVkwDMQABUgN7NmQxNmM5OTEtOThhNy00NTkxLTk3NzgtMzJjODhmZDAyMjYzfTEAAU5XAzAAAQEB
    24/02/2017 18:39:37 [ 8191] [WBXML] [test] WBXML-IN : AwFqAAAHVlIDezZkMTZjOTkxLTk4YTctNDU5MS05Nzc4LTMyYzg4ZmQwMjI2M30xAAEB
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] BackendCardDAV->Logoff(): disconnected from CARDDAV server
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] LoopDetection->ProcessLoopDetectionTerminate()
    24/02/2017 18:39:37 [ 8191] [ INFO] [test] cmd='FolderSync' memory='1.80 MiB/2.00 MiB' time='0.25s' devType='googleNexus' devId='android1487363077942' getUser='test' from='192.168.5.170' version='2.3.4+0' method='POST' httpcode='200'
    24/02/2017 18:39:37 [ 8191] [DEBUG] [test] -------- End
    Last edited by er23; 24-02-2017 at 07:49 PM.

  6. #16
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,471
    Hi er23,

    aren't there more entries in the log? It's only the FolderSync request. It would be interesting to see if the contact created on the phone is being synced to the server (and also how the log on the device looks like).

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  7. #17
    Junior Member
    Join Date
    Feb 2017
    Posts
    11
    Hi manfred,

    no, that is all.

    New test:
    - On the phone was a contact, which was earlier sync't from the server with the name "123".
    - Created a new contact on the phone with the name "New"
    -> sync removed both contacts from phone
    see the logfiles with name "*_1.log"

    Second test:
    - now there is no contact on the phone
    - added a new contact on the phone with name "New1"
    -> sync deleted "New1" and added "123" again
    see logfiles with "*_2.log

    er23
    Attached Files Attached Files
    Last edited by er23; 25-02-2017 at 02:18 PM.

  8. #18
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,471
    Hi er23,

    for the 1st test there is a contact 123 which is being synced from the server to the mobile (lines 231-360 in z-push_1.log).
    There is no entry for contact "New" in this log. So, it's either not being sent or the log was cut before.

    In z-push_2.log there's just a FolderSync without any Sync command, so that doesn't help at all.

    I don't discard the possibility that there's something wrong with the backend, but your phone also acts somewhat weird.

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  9. #19
    Junior Member
    Join Date
    Feb 2017
    Posts
    11
    Hi manfred,

    thank you for your time to investigate.
    Hmm.. the logs are definitely complete. Both logs only show one sync. For the first sync there are four "-------- Start" entries. Is this ok ?
    You wrote that for the first sync "123" was synced from server to phone, but "123" was on the phone already and was deleted with this sync.

    I wonder if i am the only one with lineageos or cyanogenmod who has this problem with z-push.

    Maybe i find time to test a stock Android the next days. Any other ideas what to test ?

    er23

Page 2 of 2 FirstFirst 12

Similar Threads

  1. wrong attachment added to mail
    By ldb1619 in forum Installation, Configuration and Maintenance
    Replies: 3
    Last Post: 17-12-2016, 12:24 PM
  2. second line added webapp
    By chomes in forum WebApp
    Replies: 2
    Last Post: 20-04-2016, 10:26 AM
  3. Replies: 0
    Last Post: 22-12-2014, 01:53 PM
  4. Can't sync user-added folders
    By swimboy in forum Z-Push when using Kopano/Zarafa
    Replies: 1
    Last Post: 20-09-2014, 04:13 PM
  5. BUG: spaces added to the subject when replying
    By sasos in forum Outlook usage Archives
    Replies: 12
    Last Post: 23-03-2009, 12:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •