Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Zarafa 7.2.5 RC is available for testing

  1. #1
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,849

    Zarafa 7.2.5 RC is available for testing

    This release of 7.2.5 has the primary focus on improving stability, security and better compatibility with certain e-mail objects.
    Next to that, as an important update ZCP 7.2.5 now officially supports the use with the latest Kopano WebApp and its plugins.
    Enhanced iCal handling, Meeting request fixes

    When an iCal object was preceded by other body text parts, the iCal description has overridden all these bodies. Also, we've previously been picking the first STD/DST timezone definition found,
    which was wrong because time zone definitions can change over time. With certain formats of meeting requests, attachments have not been stored when being accepted which has been fixed.
    Python-Zarafa, Backup and Search improvements

    In the past, words such as "cheese_cake" have not been split up both at index and search time, and therefore searching for just "cake" returned no results, for example. With ZCP 7.2.5 the underscore is used as a separator and therefore it can be found now.
    Python-Zarafa has received many stability updates, resulting in an overall improvement (stability and functionality) for all python-zarafa based services such as Kopano Search or Kopano Backup.
    SSL improvements

    With ZCP 7.2.5 we've fixed some SSL related problems as well, by example we now also recognize subjectAltNames in used SSL certificates.
    This release has received a vast (>50) amount of fixes, mainly focused on better memory management and enhancement of code segments (generally resulting in better performance and higher stability). For exact details on changes, please check the official changelog.
    When can I get a 7.2.5 final?

    Our tests and positive feedback from several partners confirm that many issues of 7.2.4 could be successfully resolved, which is why you receive this release as release candidate with fully supported release eligibility. If no new issues are found this build will be republished as the 7.2.5 final in the beginning of February.
    If you plan to upgrade your ZCP server, we strongly advise you to upgrade to this version, as Release Candidates are officially fully supported by us.
    Where can I download this new build?

    The new packages are available via our portal.
    As always we appreciate your feedback, please send us your thoughts via [email protected] or create a thread on our forum.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  2. #2
    Junior Member
    Join Date
    Apr 2014
    Posts
    28
    Quote Originally Posted by fbartels View Post
    This release of 7.2.5 has the primary focus on improving stability, security and better compatibility with certain e-mail objects.
    Next to that, as an important update ZCP 7.2.5 now officially supports the use with the latest Kopano WebApp and its plugins.
    ...
    I upgraded seamlessly on my Debian 8 server. Apart from the good practice to review all configuration files for new and changed settings, there were no issues

    However, despite your statement above that ZCP 7.2.5 is now compatible with Kopano WebApp, this cannot be installed on the same server due to dependencies on Kopano packages:
    kopano-webapp : Depends: php5-mapi (>= 8.0.0) but 7.2.5.106-127.1 is installed.
    Depends: kopano-contacts (>= 8.0.0) which is a virtual package.
    Should I understand that the two are inter-operable, but cannot be hosted on the same server?

    Is there any way to get around this?

    Andre
    IT Professional
    Zarafa 7.2.5 RC
    Z-Push 2.3.4, Outlook 2013/2016, Webapp 3.2.0

  3. #3
    Hi Andre,

    What WebApp version are you using?

    dpkg -I kopano-webapp_3.2.0.335-19.1_all.deb | grep Depends
    Depends: php5-mapi | php7-mapi (>= 7.2.5)
    Regards,

    Martyn

  4. #4
    Junior Member
    Join Date
    Apr 2014
    Posts
    28
    Hi Martyn,

    You gave me the right hint...
    I am hosting a private package repository, and forgot to run an apt-get update

    I thought I was trying to install the exact same version of webapp than you did, but I was actually trying to install 3.0.1.48-9.1, which does not work with ZCP...

    All good now.
    IT Professional
    Zarafa 7.2.5 RC
    Z-Push 2.3.4, Outlook 2013/2016, Webapp 3.2.0

  5. #5
    Glad to hear.
    It was not mentioned in the announcement but the minimal version for this to work is WebApp 3.2.0 final.

    Have a nice weekend.
    Regards,

    Martyn

  6. #6
    Senior Member
    Join Date
    Nov 2012
    Location
    Minneapolis MN, USA
    Posts
    103
    Sweet, looking forward to testing.
    David

    ---------- Post added ----------

    Question. One reason to move to 7.2.5 is being able to use the latest versions of webapp. We are under RHEL 7 with php 5.4 with 7.2.4. Is there any advice, documentation, errata, etc regarding mechanics of upgrading a 7.2.4 PHP 5.4 system to 7.2.5 PHP 5.6 system?

    Best, David

  7. #7
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,849
    Hello David,

    no there is no special documentation for this case other than the original release announcement. Basically you have to add the RHEL Software Collection, which then installs Apache 2.4 with the newer PHP version. But for RHEL 7 and PHP 5.4 you technically do not need to upgrade to a newer version (5.4 is still supported with WebApp).
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  8. #8
    Senior Member
    Join Date
    Nov 2012
    Location
    Minneapolis MN, USA
    Posts
    103
    Felix, So WebApp 3.2 doesn't require php 5.6 under RHEL 7 ?

  9. #9
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,849
    No, the general minimal required version is php 5.4 afaik.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  10. #10
    Senior Member
    Join Date
    Nov 2012
    Location
    Minneapolis MN, USA
    Posts
    103
    Quote Originally Posted by fbartels View Post
    No, the general minimal required version is php 5.4 afaik.
    Brilliant, I love it when I'm making things to complicated.

    Thanks again.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 11-08-2016, 10:06 AM
  2. [Beta] ZCP 7.2.2 beta 1 is available for testing
    By Suyi in forum Zarafa Beta Announcements
    Replies: 3
    Last Post: 27-01-2016, 01:12 PM
  3. zarafa-ws_7.1.10-44973_amd64.deb first testing
    By steffen in forum Beta Feedback
    Replies: 4
    Last Post: 12-01-2015, 09:37 AM
  4. Testing concept
    By comfreak in forum Administration and Integration
    Replies: 1
    Last Post: 19-12-2012, 10:16 PM
  5. Testing?
    By Spunner in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 04-10-2008, 03:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •