Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Error: policies' configuration file not contain default section

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    10

    Error: policies' configuration file not contain default section

    Hello,

    I installed z-push today. I am using z-push with IMAP dovecot.

    I got the following error, after install with repository:

    Your policies' configuration file doesn't contain the required [default] section. Please check the '/usr/share/z-push/policies.ini' file.

    But the section part is in the policies.ini and the www-data user is the owner of the file.

    How could I solve this problem? Thank you very much!

    Regards from Vienna! And thank you very much!

  2. #2
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi blueJack92,

    have you made any changes to the policies file? Could you post its contents? Is the file itself in /usr/share/z-push or is it symlink?

    What operating system are you using? Are there any errors in apache's error log?

    Manfred

    Edit: moved post to another subforum.
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  3. #3
    Junior Member
    Join Date
    Jan 2017
    Posts
    10
    Hello manfred,

    I am using Debian 8 as OS. I installed z-push via apt-get as recommended.

    I did not modified the policies.ini file. The file contains as symlink in /usr/share/z-push.

    Jakob

  4. #4
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi blueJack92,

    I've read in another thread that you're using php-fpm. Could it be possible that symlinked files aren't being read properly? Are there other errors in z-push.log or apache error log?

    Could you change the value of PROVISIONING_POLICYFILE in the config.php of z-push to "/etc/z-push/policies.ini" and try again? What are permissions of "/etc/z-push/policies.ini"?

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  5. #5
    Junior Member
    Join Date
    Jan 2017
    Posts
    10
    Problem found: It was not possible to prase any ini-file. Simply allow parse_ini_file in the php.ini.

    ---------- Post added ----------

    Now it's able to enter username and password on the webpage. But the login failed. I definitly entered the correct login details.

    Error-Log:

    16/01/2017 14:22:13 [27039] [ INFO] [unknown] User-agent: 'unknown'
    16/01/2017 14:22:13 [27039] [FATAL] [unknown] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
    16/01/2017 14:22:13 [27039] [ INFO] [unknown] cmd='' memory='1.49 MiB/1.75 MiB' time='0.00s' devType='' devId='' getUser='unknown' from='XX.XXX.XX.XX' version='2.3.4+0' method='GET' httpcode='401'

  6. #6
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi blueJack92,

    the getUser is unknown. Could you also post the corresponding request from apache access log? It's probably some permission missing in php.

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  7. #7
    Junior Member
    Join Date
    Jan 2017
    Posts
    10
    There are no apache access logs.

  8. #8
    Junior Member
    Join Date
    Jan 2017
    Posts
    10
    Nothing is logged about the specific URL. Where I could find more information about php permissions z-push needs?

  9. #9
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi BlueJack92,

    isn't there some php-fpm log somewhere which contains the information what's wrong? Z-Push uses quite some PHP functions and I'm not familiar with php-fpm, so it's difficult to say what permissions are missing. You could check the INSTALL file or to see if you'll find something what's not available on your system.

    As the getUser is not available, I suggest you to look if $_GET or $_SERVER variables are for some reason not available. Set the Z-Push loglevel to WBXML and post the output.

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  10. #10
    Junior Member
    Join Date
    Jan 2017
    Posts
    10
    Hello,

    no logs in php-fpm that would be interesting. I enabled the WBXML loglevel and got this:

    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] -------- Start
    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] cmd='' devType='' devId='' getUser='unknown' from='93.82.82.150' version='2.3.4+0' method='GET'
    20/01/2017 18:43:06 [12756] [ INFO] [unknown] AuthenticationRequiredException: Access denied. Please send authorisation information - code: 0 - file: /usr/share/z-push/index.php:56
    20/01/2017 18:43:06 [12756] [ INFO] [unknown] User-agent: 'unknown'
    20/01/2017 18:43:06 [12756] [FATAL] [unknown] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] ZPush::PrintZPushLegal()
    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] TopCollector(): Initialized mutexid Resource id #15 and memid Resource id #16.
    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] TopCollector initialised with IPC provider 'IpcSharedMemoryProvider' with type '20'
    20/01/2017 18:43:06 [12756] [ INFO] [unknown] cmd='' memory='1.49 MiB/1.75 MiB' time='0.00s' devType='' devId='' getUser='unknown' from='93.82.82.150' version='2.3.4+0' method='GET' httpcode='401'
    20/01/2017 18:43:06 [12756] [DEBUG] [unknown] -------- End

    getUser='unknown' - don't know why it's unknown ...

Page 1 of 2 12 LastLast

Similar Threads

  1. Error with policies.ini
    By riviera06 in forum Z-Push when using Kopano/Zarafa
    Replies: 6
    Last Post: 16-01-2017, 11:19 AM
  2. Mobile device policies
    By divB in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 20-07-2012, 12:53 AM
  3. check: no configuration file found
    By mnlgrf in forum Z-Merge Development Archives
    Replies: 3
    Last Post: 11-08-2011, 05:52 PM
  4. Change default file as in contacts
    By syscoel in forum Migration
    Replies: 1
    Last Post: 05-07-2011, 09:40 AM
  5. configuration file
    By original in forum Administration and Integration Archives
    Replies: 5
    Last Post: 06-07-2008, 06:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •