Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: iOS reconnect troubles

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    7

    iOS reconnect troubles

    Hi,

    I have z-push running smoothly, but there is this problem I can't seem to fix (it appears on iOS9 as well as iOS10).

    All is working well, except when my iPhone has no network connection at the time the push should occur. When it reconnects to the internet nothing happens: I only receive this email (and push notification) when the mail is fetched manually or when the phone is rebooted.

    Anyone also experiences this problem, and better still: know how to solve this ? :-)

    Thanks

  2. #2
    Junior Member
    Join Date
    Dec 2016
    Posts
    7
    I think I found it .... the problem is persistent with z-push 2.3.3 and it is persistent NOT an issue with z-push 2.2.x

    Guess this needs to be looked at ?

  3. #3
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    I'd say we need more logs for that ;-)

    Can you create a wbxml with 2.2 and 2.3? I'm guesing that this is probably related to the imap backend, since I cannot observe such errors on my ios device.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  4. #4
    Junior Member
    Join Date
    Dec 2016
    Posts
    7
    Hi,

    just new to z-push. Any info on where/how to create logs ?

    Tx

  5. #5
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    I've just started a little page for such questions:
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  6. #6
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi wim,

    there is also an explanation on this on the FAQ page:

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

  7. #7
    Junior Member
    Join Date
    Nov 2011
    Posts
    15
    I hate to /me too but I'm facing this problem too with 2.3.6beta1.

    A bit of background, I was supporting only Android and Windows devices up until last week but now we have our first iphone!

    Push works well for me most of the time, but occasionally, the phone will not receive updated. The moment the mail app is re-opened, the latest mails are downloaded, but no notifications or beeps indicate new mail is ready.

    After refreshing the phone, it will continue to work for a few hours, but eventually it will stall again.

    I'm using dovecot / imap, Sabredav / caldav/carddav as my backends. I don't see this problem with android devices anywhere near as frequently.

    I was wondering if there was an update to this problem, or, more appropriately is there somewhere I can look for problems (I'm happy to play inside the code)

    IOS 10.3.1 and Z-Push 2.3.6beta1 (and we 2.3.5)

  8. #8
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Unfortunately we never received logs, therefore there has been no update to this.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  9. #9
    Junior Member
    Join Date
    Nov 2011
    Posts
    15
    It's interesting, but hard to reproduce.

    So far I've seen the device issue ping requests, but not notice new emails (which I think are sync requests)
    It seems to happen after the device has switched from wifi to mobile data.

    It's really hard to reproduce reliably, but once it has taken affect the mail app must be opened in order to pull down new emails.

    I'm running at a higher log level now and I'll try to capture some information... I'm wondering what the result of the ping command is, and how z-push is letting the device know that there are new emails. I'm going to try and work out if the ping response (indicating there is new content) is being lost over the network...and subsequent new ping requests are not receiving the update.

    It's a matter of reading code / log files but I hope to come back with better questions or patches

  10. #10
    Senior Member
    Join Date
    Nov 2007
    Location
    Belo Horizonte, Brazil
    Posts
    1,475
    Hi cpitchhord,

    if there were changes, Z-Push responds with a ping status 2. The device then issues a sync request to get the changes. However if the device lost the ping connection or the connection was lost (because of a network error or a proxy or some webserver mod) then the device doesn't receive the response and won't issue the follow-up sync request. The sync will only happen when the user opens email app.

    In the past we've seen issues when using wifi and mobile data on iOS devices. For some reason these devices seem to have problems when using both connections and pings are lost.
    However it also depends on your server's configuration: is there a proxy in between, are there multiple servers with a load balancer, which webserver you're using, which mods are installed.

    But if it works fine with Android and Windows mobile devices, it's more likely that the issue is with the iphones rather than Z-Push/server configuration.

    Anyway let us know if you have some findings.

    Manfred
    Please do not PM me asking for support. Use the forum instead. Thank you.
    I usually check the mobility thread at the end of the day, so please have some patience if there's no immediate response. Asking to look at certain thread per PM won't result in a faster answer.

Page 1 of 2 12 LastLast

Similar Threads

  1. SQL reconnect Errors
    By darootler in forum Administration and Integration
    Replies: 0
    Last Post: 26-09-2014, 08:02 AM
  2. Z-push 2.0.6 / Nokia N9 Troubles (Addressbook)
    By rickstinson in forum Z-Push when using Kopano/Zarafa
    Replies: 1
    Last Post: 04-02-2013, 04:59 PM
  3. SQL Reconnect error
    By kaya in forum Installation, Configuration and Maintenance
    Replies: 5
    Last Post: 28-11-2011, 10:12 AM
  4. [SOLVED] Troubles installing Zarafa Client 702
    By niels1 in forum Installation, Configuration and Maintenance
    Replies: 4
    Last Post: 18-11-2011, 08:41 AM
  5. Outlook Profile creation troubles...
    By ern64 in forum Outlook client
    Replies: 7
    Last Post: 14-10-2011, 11:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •