Results 1 to 3 of 3

Thread: Building Web meetings from source

  1. #1

    Building Web meetings from source


    I was wondering if anyone has tried building the spreedwebrtc web meetings component of Kopano from source.

    I have downloaded the packages:

    (the latest available)

    then unpacked and did the following:


    But it says that the spreedwebrtc sourcecode in src/app isn't available. What I can see is the kopano-webmeetings directory.

    I then tried to change the configure script manually to point it to the kopano-webmeetings directory but even that fails because of missing source code.

    Does anyone know how this can be built?

  2. #2
    I managed to compile it by renaming the directory:



    But only so far on centos 7. I tried on ubuntu and did not quite succeed and not yet on Debian.

    In any case the build script generated by configure is wrong as it refers to an non existing directory.

    I have tested it within kopano webapp and it does work.

    Kopano devs... Please could you have a look at it? I think the build scripts are wrong...

    configure expects the directory to be called spreed-webrtc-server not kopano-webmeetings

    Last edited by mcost; 11-11-2016 at 05:00 PM.

  3. #3
    Senior Member
    Join Date
    Mar 2009
    At leas on gentoo, I can compile ist as kopano-webmeetings, when changing the config and automake scripts from spreed-webrtc-server to kopano-webmeetings.
    Not that big thing, but of course, it would be nice, if the scripts were correct.


Similar Threads

  1. building mailinglists
    By cdis in forum Administration and Integration
    Replies: 6
    Last Post: 23-11-2011, 10:41 AM
  2. Errors building WebApp on UCS
    By tisp in forum WebApp
    Replies: 4
    Last Post: 06-07-2011, 09:48 AM
  3. libvmime building problems
    By sargon in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 30-12-2010, 04:58 AM
  4. Try building 6.30.0 from source w/o success
    By dw2412 in forum Beta Feedback Archives
    Replies: 5
    Last Post: 26-02-2009, 07:30 PM
  5. Building Zarafa from Source fails // openSuSE 10.3 x86_64
    By Jondalar in forum Installation and Configuration Archives
    Replies: 1
    Last Post: 30-10-2008, 10:36 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts