Results 1 to 6 of 6

Thread: WebApp spellcheck can't be installed on Ubuntu 16.04 (dependency problem)

  1. #1
    Senior Member
    Join Date
    Oct 2011
    Posts
    130

    WebApp spellcheck can't be installed on Ubuntu 16.04 (dependency problem)

    [email protected]:~# apt install kopano-webapp-plugin-spell-de-de kopano-webapp-plugin-spell
    [...]
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kopano-webapp-plugin-spell : Depends: php5-enchant but it is not installable
    E: Unable to correct problems, you have held broken packages.
    Kopano 8.1.0 seems to support Ubuntu 16.04 (which comes with PHP7), as does kopano-webapp 3.1.1...
    But only if you don't want to use the spellchecker...

    Also I wonder: On the "supported" repository. Why is there a final version of WebApp for Ubuntu 16.04 but no Master version for Ubuntu 16.04? Weird :-)
    Last edited by anybody; 25-10-2016 at 03:40 PM.

  2. #2
    Hi Anybody,

    I've enabled Ubuntu 16.04 in master. Check it out
    With Spellchecker (kopano-webapp-plugin-spell_2.0.0.0-2.1_all.deb) I did not have dep conflicts on Ubuntu 16.04.

    Which version are you using of spellchecker?
    Last edited by Martyn; 26-10-2016 at 09:34 AM.
    Regards,

    Martyn

  3. #3
    Senior Member
    Join Date
    Oct 2011
    Posts
    130
    Thank you for enabling the master repository!

    I had tried this exact version but from the "final" repository (kopano-webapp-plugin-spell_2.0.0.0-2.1_all.deb is in there).
    from: download.kopano.io ==> supported ==> webapp ==> final ==> Ubuntu_16.04

    Now, after switching to the master repository the problem is gone and the dependencies work fine!
    Guess it was already fixed in Master. Thanks again!

  4. #4
    Junior Member
    Join Date
    Nov 2016
    Posts
    2
    I have to use 'final'. Is there any solution for this dependency problem?

  5. #5
    Hi ostc,

    Fixing it for the final atm, so probably will do a release tomorrow.
    I'll keep you posted.

    ---------- Post added ----------

    Hi Ostc,

    Can you check again via the final repo.
    Regards,

    Martyn

  6. #6
    Junior Member
    Join Date
    Nov 2016
    Posts
    2
    Hi Martyn,

    yes it did install! Thanks a lot!

    Greetings
    Hermann

Similar Threads

  1. WebApp Config and Ubuntu 14.04
    By joker in forum WebApp Development
    Replies: 0
    Last Post: 18-09-2016, 01:43 PM
  2. Upgrade to Ubuntu 14.04 - PHP Mapi Problem
    By ppreininger in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 29-10-2014, 04:17 PM
  3. Replies: 14
    Last Post: 17-08-2012, 11:20 AM
  4. Problem update to Ubuntu 11.04
    By madito in forum Administration and Integration
    Replies: 2
    Last Post: 05-05-2011, 10:29 AM
  5. Debian Squeeze dependency libvmime0 problem
    By zilly in forum Installation and Configuration Archives
    Replies: 21
    Last Post: 25-04-2011, 11:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •