Results 1 to 5 of 5

Thread: PHP7 crashing on Ubuntu 16.04 and Z-Push not working?

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    15

    PHP7 crashing on Ubuntu 16.04 and Z-Push not working?

    Hi,

    is it not possible to use Kopano Webapp or Z-Push on 16.04?

    Problem Nr.1:

    The Webapp is crashing the PHP7 process with SIGSEGV.

    Tried webapp-3.1.0.209_13-Ubuntu_16.04-all and webapp-3.1.0.265_234-Ubuntu_16.04-all

    PHP7.0-FPM with PHP 7.0.8-0ubuntu0.16.04.3 and php7-mapi_8.2.0.205-44.1_amd64.deb


    Problem Nr.2:

    How am I supposed to use Z-Push on Ubuntu 16.04? PHP7 is not supported and for PHP5 there is no compatible package for PHP-MAPI...


    Thanks and regards

  2. #2
    Hi,

    same thing here. Both webapp an z-push. But it seems to be related to the core packages.

    Apache segfaulted in earlier versions of core-8.1.0, and they fixed it. It was related to php7-mapi (see ).

    Version 8.2.0.185 was also not crashing when using webapp. Unfortunately, apache crashes again in 8.2.0.204 and 8.2.0.205, but obviously for a different reason. I sent a debug trace to the developers on thursday. I think, they are working on it.

    thx,
    jacks
    Last edited by jackson5; 15-10-2016 at 08:39 AM.

  3. #3
    Junior Member
    Join Date
    Nov 2011
    Posts
    15
    Hi,

    do you know if it is possible to get php-mapi built against PHP5.6 on 16.04?


    Thanks

  4. #4
    Zarafa Testing
    Suyi's Avatar
    Join Date
    Jul 2008
    Location
    irc.freenode.com > #zarafa
    Posts
    839
    hi,
    yes we are aware of this, please follow this thread ->

    ---------- Post added ----------

    Looking into that too, but the issue reported by you and the topic starter are probably different issues.
    issue that you reported, seems to be only related to Ubuntu 16.04 and the issue that is related to this topic can also be experienced on Debian 7 and 8.
    -Suyi
    Looking for users to test our releases, interested? send me a PM

  5. #5
    Junior Member
    Join Date
    Nov 2011
    Posts
    15
    core-8.2.0.247_50-Ubuntu_16.04-amd64 fixed the first issue for me.

    Any idea how to deal with the z-push issue (php7 support)?

    Thanks

Similar Threads

  1. PHP7 support
    By DocMAX in forum Z-Push when using Kopano/Zarafa
    Replies: 22
    Last Post: 29-11-2016, 08:08 PM
  2. Replies: 22
    Last Post: 20-10-2016, 10:46 AM
  3. Z-Push not working with iPhone, working in Browser
    By Dominic Pratt in forum Z-Push when using other backends
    Replies: 5
    Last Post: 04-02-2016, 06:19 PM
  4. Z-Push not working with iPhone, working in Browser
    By Dominic Pratt in forum Installation and Configuration
    Replies: 3
    Last Post: 04-02-2016, 02:01 PM
  5. z-admin on ubuntu 12.04 - ldap not working?!
    By 1of16 in forum Installation and Configuration
    Replies: 4
    Last Post: 29-04-2014, 10:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •