Results 1 to 5 of 5

Thread: files plugin preview

  1. #1
    Junior Member
    Join Date
    Mar 2013
    Location
    Germany/Ravensburg
    Posts
    20

    files plugin preview

    Hello,

    i've installed the newest zarafa version for testing (7.2.3 + WebApp 2.2.0.414-185.1) and having problems inside files (owncloud) plugin.

    Preview of images are showing "broken icon" frame but no preview of image, also downloading ist not working.
    ok.jpg

    fail.jpg

    Perhaps there is a chance to debug files plugin.

    Regards
    Debian Jessie
    Zarafa 7.2.1-51838 with Active Directory Integration and z-push
    Postfix 2.11.3
    Outlook 2010/2013, Thunderbird, WebApp, mutt

  2. #2
    Junior Member
    Join Date
    Jun 2016
    Posts
    3
    I posted the fix here

  3. #3
    Junior Member
    Join Date
    Mar 2013
    Location
    Germany/Ravensburg
    Posts
    20
    Hello johnwang,

    yes, i've already seen and integrated that, but without success.

    Looking in the apache2 logfiles i see:

    "GET /webapp/plugins/files/php/proxy.php?id=%2F0011.jpg&inline=true HTTP/1.1" 500 - ...

    Regards
    Last edited by wige; 13-06-2016 at 01:54 PM.
    Debian Jessie
    Zarafa 7.2.1-51838 with Active Directory Integration and z-push
    Postfix 2.11.3
    Outlook 2010/2013, Thunderbird, WebApp, mutt

  4. #4
    Junior Member
    Join Date
    Jun 2016
    Posts
    3
    Here's my entire proxy.php file if you'd like to give it a shot.
    If this still doesn't work, you can debug it by changing the error_reporting(0) to error_reporting(E_ALL) and uncommenting the //ini_set('display_errors', 1); line to see what's causing it to fail.


  5. #5
    Junior Member
    Join Date
    Mar 2013
    Location
    Germany/Ravensburg
    Posts
    20
    Good morning johnwang,

    you saved my day ;-) your proxy.php is working, i can see the previews.

    I included your BASE_PATH definition, the "include ... config.php" line and the class.encryptionsstore.php line and now it's o.k. I did not include the output buffering.

    Many thanks for your quick and helpful reply.

    Regards.
    Debian Jessie
    Zarafa 7.2.1-51838 with Active Directory Integration and z-push
    Postfix 2.11.3
    Outlook 2010/2013, Thunderbird, WebApp, mutt

Similar Threads

  1. Webapp Files plugin preview fix
    By johnwang in forum Zarafa WebApp Plugins
    Replies: 0
    Last Post: 06-06-2016, 01:42 PM
  2. how to install and use the files-plugin ?!
    By elmuchacho in forum Installation, Configuration and Maintenance
    Replies: 0
    Last Post: 17-06-2015, 02:04 PM
  3. Files Plugin
    By mgerste in forum Administration and Integration
    Replies: 2
    Last Post: 13-04-2015, 08:56 AM
  4. Webapp2 Files-Plugin Problem
    By Balou84 in forum WebApp
    Replies: 7
    Last Post: 09-03-2015, 02:52 PM
  5. Files Plugin
    By mikescholes in forum WebApp
    Replies: 0
    Last Post: 29-01-2015, 02:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •