Results 1 to 9 of 9

Thread: Plugins directory '/var/lib/zarafa/dagent/plugins' doesn't exists. Plugins not loaded

  1. #1

    Plugins directory '/var/lib/zarafa/dagent/plugins' doesn't exists. Plugins not loaded

    Dear all,

    I am on Zarafa 7.2.3.657. It's an Ubuntu 14.04 LTS 64 bit server Zarafa is running on.
    The zcp services are configured to run with regular user privileges.

    Mail delivery with procmail calling dagent works, although the server.log gets a

    on each delivery.

    dagent is called like this:

    I set procmail logging to verboose and got this:
    The error occurs although the directory exists.
    I tried laxing and changing the ownership of the plugins directory, but that did not change anything.

    If you need further information or testing – do not hesitate to ask.

    Thanks,

  2. #2
    Zarafa Testing
    Suyi's Avatar
    Join Date
    Jul 2008
    Location
    irc.freenode.com > #zarafa
    Posts
    839
    Hi Ralph,
    --removed
    did you run the symlink command which is mentioned over here? ->
    meanwhile we will try to reproduce this issue.
    -Suyi
    Last edited by Suyi; 13-05-2016 at 12:54 PM.
    Looking for users to test our releases, interested? send me a PM

  3. #3
    No, I did not do this during installation, so neither /var/lib/zarafa/dagent/plugins/movetopublic.py nor /etc/zarafa/movetopublic.cfg were in place.

    I stopped the dagent service, issued the above commands and startet the service again, but the error is the same:
    There is a plugin now in the plugin directory, but it still fails to access the plugin directory itself.

    Thanks,

  4. #4
    Good morning,

    I tried upgrading to 7.2.3 on Debian 8

    I get exactly the same problem described above.

    I tried debugging it by simply typing:

    echo "hello" | /usr/sbin/zarafa-dagent -c /etc/zarafa/dagent.cfg mrc

    (mrc is my zaraf username)

    And with full logging (level 6) I get the following:

    Wed May 18 09:03:58 2016: [ 6015] [debug ] StatsClient binding socket
    Wed May 18 09:03:58 2016: [ 6015] [debug ] StatsClient bound socket to /tmp/.3650426c2f71d7b.sock
    Wed May 18 09:03:58 2016: [ 6015] [debug ] StatsClient thread started
    Wed May 18 09:03:58 2016: [ 6015] [debug ] PYTHONPATH = /usr/share/zarafa-dagent/python
    Wed May 18 09:03:58 2016: [ 6015] [debug ] Submit thread started
    Wed May 18 09:03:58 2016: [ 6015] [info ] * Loading plugins started
    Wed May 18 09:03:58 2016: [ 6015] [warning] ! Plugins directory '/var/lib/zarafa/dagent/plugins' doesn't exists. Plugins not loaded.
    Wed May 18 09:03:58 2016: [ 6015] [error ] M4LMsgServiceAdmin::ConfigureMsgService() MSGServiceEntry failed 80040111: logon failed


    When I look in the zarafa-server log I get the following:

    Wed May 18 09:03:58 2016: [warning] Failed to authenticate user "SYSTEM" from "file:///var/run/zarafad/server.sock" using program "zarafa-dagent"
    Wed May 18 09:03:59 2016: [error ] Unable to open attachment "/var/lib/zarafa/attachments/5/11/361515" for writing: Permission denied


    Any help much appreciated. As it is now I am unable to upgrade.

    Again all I did was to get the packages for 7.2.3, install them, and restart the system.

    Everything works other than this, but it does mean that I cannot upgrade as e-mails cannot be deliverd at all.
    Last edited by mcost; 18-05-2016 at 09:11 AM.

  5. #5
    Hi Suyi,

    I was wondering if you were able to replicate the problem.

    I can debug further if you would like me to send you any more logs but as it is now I am stuck...

  6. #6
    Hi Suyi,

    could you please provide an update?
    Could the devs reproduce the issue?
    Is it assigned already?

    Thanks,

  7. #7

    Indeed as it is now, zcp 7.2.3 is broken for me... I can't upgrade whatsoever (although I would like to).

  8. #8
    Zarafa Development

    Join Date
    Jan 2016
    Posts
    10
    Unless the manual disagrees with me, I would say dagent is only supposed to be run by the users listed in server.cfg's "local_admin_users". And I doubt that the user running procmail in your case is an admin.

  9. #9
    I see... interesting.

    I have been running the same setup for that setting with server.cfg for years... And with .procmailrc it was running absolutely fine.

    Perhaps something has changed in 7.2.3 (I am running 7.2.1) that enforced that setting going forward?

    Either way I will give it a try and report back.

    Thanks for your reply

Similar Threads

  1. Replies: 1
    Last Post: 07-04-2016, 02:51 PM
  2. Replies: 5
    Last Post: 22-06-2015, 11:50 AM
  3. dagent plugins not loading
    By devnull in forum Administration and Integration
    Replies: 0
    Last Post: 08-04-2014, 05:53 AM
  4. Zarafa 6.30.4 Plugins
    By bartdaniels in forum WebAccess usage Archives
    Replies: 1
    Last Post: 01-11-2009, 12:57 PM
  5. English lang with zarafa-webaccess-6.30 with plugins
    By antond in forum Z-Merge Development Archives
    Replies: 6
    Last Post: 22-04-2009, 12:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •