Results 1 to 10 of 10

Thread: Attachment Error Migrating to new Server

  1. #1
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14

    Attachment Error Migrating to new Server

    Hello maybe you can help me,


    i migrated to a new maschine. i took a dump from the sql database and copied the filebase attachments. but now users can´t access serveral attachments.


    this is the server.log from zarafa



    ECFileAttachment::LoadAttachmentInstance(SOAP): Error while gzreading attachment data from /data/zarafa/attachments/3/13/1093733.gz
    gzread: <fd:18>: data error (-3)


    the new installtion is running and everything is working except the serval attachments.



    thanks for your advise

  2. #2
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Hello raiden,

    several questions come to my mind:
    - which version is in use now and was before?
    - is the path in server.cfg set to the actual location attachments are stored?
    - are there errors for all attachments or only for some?
    - is the file given in the error message present on the system?
    - can it be extracted/viewed with gunzip?
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  3. #3
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14
    hello fbartels,

    several questions come to my mind:
    - which version is in use now and was before?
    the version is the same again 7.1.14-51822.

    - is the path in server.cfg set to the actual location attachments are stored?
    the path in the server.cfg is set to the right path in the filesystem

    - are there errors for all attachments or only for some?
    the errors are with some attachments, some are working and some are not working

    - is the file given in the error message present on the system?
    yes the file is on the system


    - can it be extracted/viewed with gunzip?
    the file can´t be extracted on my local maschine



    so is it possible that the attachments are broken from the old maschine? is there a trick to check the whole attachment folder?

  4. #4
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    In that case the file got corrupted during transfer. There is no real "--check-attachments" in zarafa-server, but since everything is on the disk anyway you could just iterate over all files (with a simple find /attachmentdir -name *.gz) and then run the "file" command on each match (with the exec option of file for example). File will print the filetype for every item and should also give an error if it can't get the filename (because of the corrupted gzip).

    Its probably easier to just transfer all old attachments over via rsync, which will overwrite files that are already in place, but are not the same as the source.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  5. #5
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14
    so i checked the old maschine and the attachments are broken too. so i think it dont make sense to copy / rsync the old attachments to the old maschine but thanks for your advise

  6. #6
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14
    i managed to restore a backup from the attachments. now i can open the files on my locale linux maschine but in the webacces and outlook it cant be opened. the server log is clean no errors

    ---------- Post added ----------

    but when i download it to my local system via webaccess there is the problem the data is 0 bytes

  7. #7
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14
    someone has an advise?

  8. #8
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Hi,

    before you got an error because the file was there, but could not be read (error when uncompressing). When you get the 0 byte response zarafa-server either cannot find the attachment or cannot read it at all. Have you placed it at the correct location? is it compressed or uncompressed?
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  9. #9
    Junior Member raiden2332's Avatar
    Join Date
    Jan 2013
    Location
    Stade
    Posts
    14
    now the data is valid when i download the data it is ok. but in the webaccess the error is still present.

  10. #10
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Maybe just a caching error? When it works in one client, there is no reason for it to not work in others. Anyway, maybe you should use this as an incentive to switch to WebApp ;-)
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

Similar Threads

  1. Migrating yaffas to a new server
    By raceface2nd in forum Migration
    Replies: 0
    Last Post: 26-01-2015, 08:52 PM
  2. migrating zarafa server to a new hardware
    By sbdcunha in forum Migration
    Replies: 0
    Last Post: 26-01-2015, 08:34 AM
  3. Migrating Contacts from one Zarafa Server to new one
    By teufel2k in forum Installation, Configuration and Maintenance
    Replies: 6
    Last Post: 17-01-2012, 05:48 PM
  4. Migrating Zarafa to a new server
    By mvdwalle in forum Migration
    Replies: 5
    Last Post: 29-08-2011, 11:08 AM
  5. Server usage problem when migrating
    By arthur in forum Migration Archives
    Replies: 16
    Last Post: 07-02-2008, 09:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •