Results 1 to 10 of 10

Thread: Zarafa-search, MAPI error 8004010F

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    15

    Exclamation Zarafa-search, MAPI error 8004010F

    Zarafa-search throws following error in the log file when the user "browses" his folders (Note, a full index of the store has been performed).
    Has anyone seen that before ?
    For information, we are running ZCP 7.2.2-481 (Beta 2), Webapp 2.1.2 on Debian 8.

    Thanks,
    Fabian

    2016-03-07 09:37:55,661 - search - INFO - starting search
    2016-03-07 09:37:55,779 - search - INFO - found previous server sync state: FF210000C8CF0500
    2016-03-07 09:37:55,791 - search - INFO - starting incremental sync
    2016-03-07 09:37:55,828 - query - INFO - listening on socket file:///run/zarafad/search.sock
    2016-03-07 09:38:46,881 - query - INFO - Command: PROPS
    2016-03-07 09:38:46,881 - query - INFO - Response: OK:125 100 3102 117 26510 26511 26
    2016-03-07 09:38:57,658 - index0 - INFO - syncing folder: E2A3CF7013414CF292B4C5835513B56F Freebusy Data
    2016-03-07 09:38:57,662 - index0 - INFO - found previous folder sync state: 27230000C7CF0500
    2016-03-07 09:38:57,702 - index1 - ERROR - Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/zarafa/__init__.py", line 3574, in log_exc
    try: yield
    File "/usr/lib/python2.7/dist-packages/zarafa_search/__init__.py", line 154, in main
    if folder not in (store.junk, store.outbox):
    File "/usr/lib/python2.7/dist-packages/zarafa/__init__.py", line 1268, in junk
    return Folder(self, HrGetOneProp(self._root, PR_ADDITIONAL_REN_ENTRYIDS).Value[4])
    File "/usr/lib/python2.7/dist-packages/MAPI/Defs.py", line 45, in HrGetOneProp
    raise Struct.MAPIError.from_hresult(props[0].Value)
    MAPIErrorNotFound: MAPI error 8004010F

    2016-03-07 09:38:58,326 - index0 - INFO - saved folder sync state: 27230000CBCF0500
    2016-03-07 09:38:58,327 - index0 - INFO - syncing folder E2A3CF7013414CF292B4C5835513B56F Freebusy Data took 0.66 seconds (1 changes, 0 attachments)
    2016-03-07 09:38:58,369 - index0 - ERROR - Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/zarafa/__init__.py", line 3574, in log_exc
    try: yield
    File "/usr/lib/python2.7/dist-packages/zarafa_search/__init__.py", line 154, in main
    if folder not in (store.junk, store.outbox):
    File "/usr/lib/python2.7/dist-packages/zarafa/__init__.py", line 1268, in junk
    return Folder(self, HrGetOneProp(self._root, PR_ADDITIONAL_REN_ENTRYIDS).Value[4])
    File "/usr/lib/python2.7/dist-packages/MAPI/Defs.py", line 45, in HrGetOneProp
    raise Struct.MAPIError.from_hresult(props[0].Value)
    MAPIErrorNotFound: MAPI error 8004010F

    2016-03-07 09:38:58,384 - index1 - INFO - syncing folder: E2A3CF7013414CF292B4C5835513B56F Freebusy Data
    2016-03-07 09:38:58,386 - index1 - INFO - found previous folder sync state: 27230000CBCF0500

    ...

  2. #2
    Junior Member
    Join Date
    May 2012
    Posts
    15
    i've added some debug output to the indexer job, and it turns out that the issue occurs on a folder called "Zarafa 1" belonging to store of user "None"..
    Something wrong with one of my stores ?

    EDIT: Turns out the culprit is the "Public store". The issue occurs whenever the "Junk" folder is attempted to be retrieved on the Public Store. (HrGetOneProp(self._root, PR_ADDITIONAL_REN_ENTRYIDS) is null / None)
    The issue is reproducible. Whenever the "Public store" gets unhooked / deleted, the issue disappears. As soon as a new Store is created, the issue shows up again.

    Can anyone open a ticket for this please ?

    Thanks,
    Fabian
    Last edited by Fabian; 08-03-2016 at 10:37 AM.

  3. #3
    Junior Member
    Join Date
    May 2012
    Posts
    15
    Fixed in 7.2.2 RC1
    [ZCP-13818] and [ZCP-13567]

  4. #4
    Senior Member
    Join Date
    Jan 2008
    Posts
    400
    For others..

    After an upgrade from 7.2.1 to 7.2.3 i saw the same problem.

    Due to the previous search errors i disabled my zarafa servers in version 7.2.1

    I re-enabled it again in 7.2.3, run as zarafa user/group so chown -R on the /var/lib/zarafa folder.
    I noticed none of the files and folders where getting updated.

    On this server is have a small database so my fix as.

    stop zarafa-search
    removed all content and folders from : /var/lib/zarafa/search/

    and started zarafa search again.
    and the errors are gone now, its indexing again.

  5. #5
    Member
    Join Date
    May 2009
    Location
    Hamburg, Germany
    Posts
    49
    Same problem here. Thanks for the tip. Its works for me.

  6. #6
    Junior Member
    Join Date
    Oct 2011
    Posts
    21
    Same here:

    Version is

    Product version: 7,2,5,109
    File version: 109


    What do do now?
    cu

    netlord

  7. #7
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Have you tried

    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  8. #8
    Junior Member
    Join Date
    Oct 2011
    Posts
    21
    Hallo Felix

    Well - I don´t have this folder.

    even after dpkg -i zarafa-search-plus_7.2.5.109-137.1_amd64.deb

    P.S. System is Debian 8
    cu

    netlord

  9. #9
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    your search.cfg should be able to tell you, where you are storing your search database.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  10. #10
    Junior Member
    Join Date
    Oct 2011
    Posts
    21
    OK, that helped.
    Deleting and checking.

    Thank you!
    cu

    netlord

Similar Threads

  1. php-mapi: MAPI error: 8004010f in /var/log/maillog
    By zolo in forum Administration and Integration
    Replies: 12
    Last Post: 13-03-2016, 09:48 AM
  2. MAPI error: 8004010f
    By mmain in forum Outlook client
    Replies: 4
    Last Post: 24-10-2015, 04:24 PM
  3. search.log - MAPI error or timeout
    By caldwell in forum Beta Feedback
    Replies: 4
    Last Post: 17-09-2015, 06:23 AM
  4. 7.2 zarafa-server Error while connecting to search on file:///var/run/zarafa-search
    By caldwell in forum Installation, Configuration and Maintenance
    Replies: 8
    Last Post: 09-09-2015, 09:01 PM
  5. Replies: 1
    Last Post: 06-09-2015, 08:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •