Results 1 to 3 of 3

Thread: Created Plugin or Widget won't run

  1. #1
    Junior Member
    Join Date
    Jan 2011
    Posts
    2

    Question Created Plugin or Widget won't run

    Hey Guys,

    I try to write a Plugin that Display the Store Size (Capacity) much more in the main Part of the Webapp Frontend. I think no User look under the Settings Part.
    My Problem is i try to write it as Widget and as Plugin Version but Both won't run under my Zarafa Server :-/. The Plugin is not shown under Settings->Plugins and the same with the Widget.

    Where can i search for my Problem.

    The Support say i should write it in this Area of the Forum not in the Webapp Development Area.

    Zarafa Server Version: ZCP 7.2.0-48204
    Webapp Version: WebApp 2.1.1

    This is only Testing Code ;-) not the finish Version

    Widget Version
    manifest.xml
    js/zstorewidget.js
    Plugin Version
    manifest.xml
    js/zstorewatch.js
    Last edited by Snopy1007; 03-02-2016 at 08:46 AM.

  2. #2
    Junior Member
    Join Date
    Jan 2011
    Posts
    2
    Nobody a Answer? :-(

  3. #3
    Hi Snopy,

    I'm not a developer, but it looks like this is not correct:
    - container.registerWidget expects an object as parameter.
    - Dir name, widgetname in manifest and widgetname should be identical. Your plugin is not loaded at all, because javascript does know it exist.

    Maybe this can help:
    Regards,

    Martyn

Similar Threads

  1. Chat widget missing in webapp
    By greavette in forum Installation, Configuration and Maintenance
    Replies: 7
    Last Post: 27-07-2015, 02:56 PM
  2. Widget
    By neverbend007 in forum PHP Development
    Replies: 1
    Last Post: 19-03-2014, 08:18 AM
  3. all flagged items widget
    By jmalt in forum WebApp
    Replies: 1
    Last Post: 11-11-2013, 01:53 PM
  4. Webapp Widget issue on Synology 712+
    By Badack in forum Installation, Configuration and Maintenance
    Replies: 0
    Last Post: 13-08-2012, 02:17 PM
  5. Create a simple widget or plugin in webapp that posts an url
    By ebogaard in forum WebApp Development
    Replies: 3
    Last Post: 16-07-2012, 11:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •