Results 1 to 3 of 3

Thread: using PHP 5.4 ?!

  1. #1
    Senior Member
    Join Date
    Sep 2009

    using PHP 5.4 ?!

    i would like to give the new files-plugin a try.
    But it requires PHP 5.4.
    Currently I'm running Ubuntu 12.04 LTS x64 with PHP 5.3.
    Found a tipp to get PHP 5.4 up and running on 12.04.
    But this will remove yaffas and zarafa ...

    Are the dependencies for yaffas and zarafa set to PHP 5.3?


    current system : ZARAFA 7.1.13 on Ubuntu 12.04 LTS (x64) with Z-Admin
    user base : WIN 2008 R2 (x64) with ADS-plugin ...
    backups are overvalued ...
    restore is important ...

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Yes, dependencies are propbably fixed at the Ubuntu-provided versions. However, this is not a yaffas-specific issue. The dependency comes from php-mapi, which is a Zarafa-provided package. So you would need to build your own Zarafa packages, I guess. Might be easier and better to switch to Ubuntu 14.04 or something else with recent PHP...

  3. #3

    Join Date
    Jan 2009
    Hanover, Germany
    As far as I heard there are plans to make the new files plugin compatible with php 5.3 or the next public iteration. So depending on how you want to wait you could also wait for the next release.

    On second thought, newer owncloud releases also depend on more recent php versions. So in case everything is running on the same box an update would certainly not hurt.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: > #zarafa
    Zarafa documentation:

    No support via PM! Please contact our sales team for an offer if you want my full attention.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts