Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: Webaccess no login

  1. #21
    The permission issue is another issue.
    If you want to investigate further:
    Don't quote me on this, but the WebAccess isssue could be related to a config option.
    Regards,

    Martyn

  2. #22
    Hi Martyn,

    Thanks for your reply. Not sure what config option though, are you referring to the webaccess config.php file?

    For this test installation I have everything running on the same machine, that is zarafa-server and httpd and zarafa-webaccess therefore the config files should work out of the box?

    The thing I am stuck with is that I am unable to generate any logging whatsoever.

    Is there any way to enable logging further?

  3. #23
    Junior Member
    Join Date
    Oct 2015
    Posts
    14
    Its hard to believe that only a few people have this issue, when this is happening in a fresh installation, reason why this is not handled with higher priority.

  4. #24
    Yeah in config.php. That could be a start for your investigation.
    But like I said it could be related. I'm not certain
    Last edited by Martyn; 10-12-2015 at 09:58 PM.
    Regards,

    Martyn

  5. #25

    Thank you, I will have a look again, but when I did last time, it looked exactly as all other config.phps I had before...

    I am more concerned about not being able to see any log files at all...

    Is there any way to increase logging to work out what's going on?

  6. #26
    checked and the config.php is the same as it is in the older versions of Zarafa where it works perfectly...

    So I am out of ideas.

  7. #27
    I suspect perhaps most people are still running Centos 6 or older builds therefore the issue will appear as they move to Centos 7...

  8. #28
    Senior Member
    Join Date
    Jan 2008
    Posts
    400
    Hai,
    i'll try to help you out where i can, i have seen this before, but cant recall the exact solution.
    I dont have centos here, but i know a few things, i dont think this is a zarafa problem, but setting problem.

    Few questions so we know where to start to check from.

    do you run as root or as user ?
    if you run as user, recheck all needed rights.
    like :
    /var/log/zarafa zarafa_user:zarafa_group
    /var/lib/zarafa zarafa_user:zarafa_group
    /etc/zarafa/report zarafa_user:zarafa_group 755


    check the rights on the socket ( for me /var/run/zarafa 666)

    are you using define("DEFAULT_SERVER ... The default /var/run ?

    lets start from here.

  9. #29
    Hi,

    Apologies for the delay

    Everything runs as root other than the web server that runs as apache.
    For the log directory:

    drwxr-x---. 2 zarafa zarafa 4096 Nov 29 03:34 zarafa

    I can see in fact files being written normally in there.

    For the lib directory:

    /var/lib/*zarafa*

    I can see:

    [[email protected] lib]# ls -rtl |grep -i zarafa
    drwxr-x---. 4 zarafa zarafa 37 Oct 29 11:09 zarafa
    drwxr-xr-x. 3 root root 16 Oct 29 11:10 zarafa-webaccess
    drwxrwx--- 3 root apache 16 Nov 28 18:09 zarafa-webapp


    But I can see things being created in:
    /var/lib/zarafa-webaccess/tmp/session

    such as:
    -rw-r--r-- 1 apache apache 30 Feb 7 18:19 0rbgam4c90qclbu8pfrg4tqiv7.plugin
    -rw-r--r-- 1 apache apache 7563 Feb 7 18:19 0rbgam4c90qclbu8pfrg4tqiv7.webclient1454869156324
    -rw-r--r-- 1 apache apache 30 Feb 7 18:19 pdbdcgcvim86500d5hvucqhep6.plugin
    -rw-r--r-- 1 apache apache 30 Feb 7 18:19 bkoet0urvakv4tu5d9nnhgsif6.plugin
    -rw-r--r-- 1 apache apache 30 Feb 7 18:20 do8o36u3q3vvsdh34bq0hdm742.plugin



    Finally, in:
    /etc/zarafa/webaccess-ajax/config.php

    I can see the following:

    // Default Zarafa server to connect to.
    define("DEFAULT_SERVER","file:///var/run/zarafa");


    I tried removing webaccess and reinstalling from scratch but the problem is the same...

    In var/run I can see the following:

    srw-rw-rw- 1 root root 0 Feb 7 18:15 zarafa

    Which I believe is correct as webapp works fine...

    I am out of ideas.

    Very much appreciated.

    It's ashame as everything else works perfectly well and we are ready to move away from the older versions but we can't till this is resolved...
    Last edited by mcost; 07-02-2016 at 07:33 PM.

  10. #30
    we would like to migrate to RHEL 7 but we can't as some users are refusing to move from webaccess to webapp...

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 08-09-2014, 09:10 PM
  2. i can't login to the webaccess...
    By aleks1 in forum WebAccess
    Replies: 1
    Last Post: 28-04-2014, 08:52 AM
  3. [solved] Webaccess Login
    By Chris81 in forum Installation, Configuration and Maintenance
    Replies: 6
    Last Post: 25-06-2011, 01:29 PM
  4. users cannot login webaccess
    By funganz in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 31-05-2011, 07:19 AM
  5. webaccess login then back to the login screen
    By lamvt in forum Installation and Configuration Archives
    Replies: 3
    Last Post: 09-01-2010, 10:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •