Results 1 to 3 of 3

Thread: External SMTP Auth is not working (SASL LOGIN authentication failed)

  1. #1
    Senior Member
    Join Date
    Dec 2010
    Location
    near Celle, Germany
    Posts
    187

    External SMTP Auth is not working (SASL LOGIN authentication failed)

    Hi,

    I got a little problem and can't find the solution.
    Some time ago I was able to send emails via my zarafa-server from _external_ application (like my NAS) after one of the last updates it won't work again:
    [code]SASL LOGIN authentication failed: authentication failure[code]

    the "noreply"-user is enabled for imap (imap and pop3 are firewalled, smtp is, ofc, enabled), because I remembered it is necessary to use smtp.
    following the "interesting" configs:
    main.cf/etc/default/saslauthd
    /etc/postfix/sasl/smtpd.conf
    sasl2-bin is installed, ubuntu 14.04.3 with the latest stable zadmin release. I double checked the username / password of the noreply user and even this is not working:
    I know its a tiny and maybe even stupid configuration error, but, to be honest, I forgot how I figured it out the last time.

    hope someone (christian? ) can help me.

    greetings
    1of16
    Last edited by 1of16; 15-09-2015 at 10:02 AM. Reason: typo

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hm, I do not see any obvious mistakes from a first glance.
    Does the auth request get through to zarafa-gateway/zarafa-server? I would checke their logs, maybe after increasing the relevant log_levels.

  3. #3
    Senior Member
    Join Date
    Dec 2010
    Location
    near Celle, Germany
    Posts
    187
    now its getting interesting
    gateway-log:
    server-log:
    I just deleted the user and created it again, changed the "username" in the external application from to noreply....and now its working.

    This is kinda confusing but now its working...so everything is alright
    thank you Christian for your help!

Similar Threads

  1. Need help in smtp auth relay
    By sreeks3986 in forum Installation, Configuration and Maintenance
    Replies: 3
    Last Post: 28-05-2015, 10:38 PM
  2. SASL authentication failed
    By raceface2nd in forum Administration and Integration
    Replies: 6
    Last Post: 16-07-2014, 04:33 PM
  3. SASL authentication failure
    By imochen in forum Administration and Integration
    Replies: 1
    Last Post: 26-06-2012, 11:46 AM
  4. Revert to password auth when NTLM auth (SSO) failed
    By in forum Administration and Integration Archives
    Replies: 2
    Last Post: 12-02-2009, 11:52 PM
  5. SMTP AUTH
    By daudo in forum Installation and Configuration Archives
    Replies: 5
    Last Post: 03-08-2008, 08:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •