Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: [RC] Zarafa WebApp 2.1.0 RC1 is now available!

  1. #11
    Senior Member
    Join Date
    Nov 2011
    Location
    South West London, United Kingdom
    Posts
    178
    @martyn just checked and spellchecker is not enabled on webapp by default even though config is defined as true. You must manually enable it.
    IT Engineer,
    ClearOS 5.2, Zarafa 7.1.x
    ClearOS 6.5, Zarafa 7.1.10-7.2.x

  2. #12
    Member
    Join Date
    Dec 2010
    Location
    Wr. Neustadt, Austria
    Posts
    51

    Spell checker problem with German languages

    Hi,

    I updated to RC1 and installed 3 language plugins, de_AT, de_DE and en_US. Added this 3 languages to config-spellchecker.php

    define('PLUGIN_SPELLCHECKER_SELECTED_LANGUAGES', 'de_AT, de_DE, en_US');

    restarted apache2.


    Only language en_US works, both German languages I get this error message: "Enchant spellchecker could not find dictionary for language: de_AT"
    Any ideas how to solve this issue?

    Also in file "config-spellchecker.php" the closing "?>" sequence is missing.
    Regards

    Walter

  3. #13
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hi Walter,

    Hm, looks like the enchant dictionary path handling had to be extended by Zarafa to allow for the current packaging structure. Maybe there is some problem in this area. I guess I would try to start debugging this by throwing debug code into EnchantEngine.php (var_dump($config["enchant_dicts_path"]); or something) in order to figure out if the correct paths have been configured. Starting with that one could probably trace down the root cause. Maybe I will have time to look at this on a dev system. What distribution are you on?

    Regarding the "missing" closing tag: That might be by intention. It is allowed and may be used to avoid trailing non-PHP data in such a file (such as new lines) which would break PHP header handling.

    Kind regards,

    Christian

  4. #14
    Member
    Join Date
    Dec 2010
    Location
    Wr. Neustadt, Austria
    Posts
    51
    Hi Christian,

    >> "What distribution are you on?"
    this is a fully patched SLES 11 SP3 X64 system.

    >> "Regarding the "missing" closing tag: That might be by intention."
    all other config.php files contain the closing tag.
    Regards

    Walter

  5. #15
    Member
    Join Date
    Dec 2010
    Location
    Wr. Neustadt, Austria
    Posts
    51
    From Zarafa support I got this helpful information:

    zypper in aspell-de

    This fixed the issue.
    Regards

    Walter

  6. #16

    rc1 for zarafa 7.1

    Question: does this release work with zarafa server 7.1 or only with zarafa server 7.2 onwards?

  7. #17
    Senior Member
    Join Date
    Nov 2011
    Location
    South West London, United Kingdom
    Posts
    178
    @mcost we have 7.1.10 on our server and using webapp 2.1.0 release 7.2 isn't necessary it's only there to help enhance searching for the new webapp.
    IT Engineer,
    ClearOS 5.2, Zarafa 7.1.x
    ClearOS 6.5, Zarafa 7.1.10-7.2.x

  8. #18
    Junior Member
    Join Date
    Jul 2013
    Posts
    7
    Hi,

    1.) The package "zarafa-webapp-plugins-spell-1.0-21.1.noarch" needs the php-enchant, but this is not available for SLES 11 SP3 standard installation with all patches.

    rpm -i zarafa-webapp-plugins-spell-1.0-21.1.noarch.rpm

    warning: zarafa-webapp-plugins-spell-1.0-21.1.noarch.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID fb3045b0
    error: Failed dependencies:
    php-enchant is needed by zarafa-webapp-plugins-spell-1.0-21.1.noarch

    zypper search php53-enchant
    Refreshing service 'nu_novell_com'.
    Loading repository data...
    Reading installed packages...
    No packages found.


    2.) SSO in WebApp have a big security problem


    Regards,
    Thomas

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Zarafa 7.1.12 without webapp?
    By Thomas M. in forum Installation, Configuration and Maintenance
    Replies: 5
    Last Post: 29-06-2015, 02:46 PM
  2. Zarafa Webapp v 1.6
    By solidsjakie in forum WebApp
    Replies: 31
    Last Post: 21-11-2014, 09:48 AM
  3. [Final] Zarafa WebApp 1.2
    By Robin in forum Zarafa Announcements
    Replies: 1
    Last Post: 19-10-2012, 11:28 PM
  4. Webapp in Zarafa 7.0.7
    By Fabian in forum WebApp
    Replies: 7
    Last Post: 30-06-2012, 11:22 AM
  5. Zarafa Webapp 1.1
    By Robin in forum Zarafa Announcements
    Replies: 0
    Last Post: 20-06-2012, 12:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •