Results 1 to 5 of 5

Thread: PHP-MAPI and HHVM

  1. #1
    Junior Member
    Join Date
    Nov 2011



    are there any plans to support hhvm () in future releases of Zarafa? It seems the PHP-MAPI extension is the dealbreaker in this case.

    Thanks and regards

  2. #2
    Senior Member
    Join Date
    Feb 2008
    Leonberg, Germany
    IANAZE (I am not a Zarafa employee), but did you already cross-check if the Zend compat layer of HHVM might help here?
    I install, configure, customize, integrate and maintain Zarafa setups in different environments since 2007. If you want my full attention, please send me a private message and ask for paid support.

  3. #3
    Junior Member
    Join Date
    Nov 2011
    Well, even if I run HHVM with the "hhvm.enable_zend_compat = true" option I still get the following error:

  4. #4
    Junior Member
    Join Date
    Nov 2011
    Any news on this with Kopano?

  5. #5

    Join Date
    Jan 2009
    Hanover, Germany
    Hello Virusmoere,

    your thread was just brought to my attention. We are aware of HHVM for quite some time now, but currently don't regard it as a priority for us. If you are willing to work on this and contribute patches/howtos to get this running we'll gladly consider taking it upstream though.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: > #zarafa
    Zarafa documentation:

    No support via PM! Please contact our sales team for an offer if you want my full attention.

Similar Threads

  1. php-mapi: MAPI error: 8004010f in /var/log/maillog
    By zolo in forum Administration and Integration
    Replies: 12
    Last Post: 13-03-2016, 09:48 AM
  2. Outlook without MAPI
    By wige in forum Z-Push when using Kopano/Zarafa
    Replies: 0
    Last Post: 18-03-2015, 02:03 PM
  3. mixed mode: mapi user and no-mapi user
    By mindpack in forum Installation, Configuration and Maintenance
    Replies: 2
    Last Post: 01-09-2011, 09:09 AM
  4. PHP-MAPI files
    By Clorith in forum PHP Development Archives
    Replies: 1
    Last Post: 14-12-2010, 09:01 PM
  5. PHP 5.2.9, CentOS 5.3 and
    By Dacira in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 10-04-2009, 12:07 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts