Results 1 to 3 of 3

Thread: Excessive Zarafa socket use makes server unusable (long)

  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    26

    Excessive Zarafa socket use makes server unusable (long)

    Hi all!

    I run the following Zarafa configuration:


    After an update to Zarafa 7.1.12, I noticed that my server sometimes throws errors that Postfix is not able to connect to OpenLDAP, or that squid (running on the same box) is not able to open a socket connection. Using netstat, I noticed that sometimes more that 20000 (!!) OpenLDAP connections are in TIME_WAIT state, which is an explanation why the system runs out of sockets.

    In order to identify the source of the connections, I added a second local port to OpenLDAP and configured only Zarafa to connect to this port, while all other processes connecting to OpenLDAP (i.e. postfix/proxymap, saslauthd, apache, remote computers, etc.) use the original one. I also reduced the time-out of the TIME_WAIT sockets to 10 seconds by setting .

    Using the trivial shell script below, I recorded the number of open OpenLDAP sockets every 5 seconds. An excerpt of the resulting plot is attached (note the log scale of the socket count).

    As you can see in the plot, the number of sockets is periodically extremely high - the maximum is 16915, of which 16895 are in TIME_WAIT state. Apparently, Zarafa keeps 19 sockets permanently open (blue curve). Compared to that, the load by all other processes accessing OpenLDAP (red and green curves) is very low.

    Is this a "known" feature/bug of Zarafa? Or did I mis-configure something in the server?

    Any insight would be highly appreciated,
    thanks in advance,
    Albrecht.

    Shell script for recording the OpenLDAP connections (Zarafa connects to port 9389, all other processes to 389 or 636):

    Attached Images Attached Images

  2. #2
    Senior Member
    Join Date
    Feb 2008
    Location
    Leonberg, Germany
    Posts
    273
    I am unfortunately able to see a similar behaviour since Zarafa 7.1.12, looks like the LDAP specific changes and rewrites of this release were not that great...
    I install, configure, customize, integrate and maintain Zarafa setups in different environments since 2007. If you want my full attention, please send me a private message and ask for paid support.

  3. #3
    Zarafa Testing
    Suyi's Avatar
    Join Date
    Jul 2008
    Location
    irc.freenode.com > #zarafa
    Posts
    839
    Hi Albrecht,

    I would propose to contact support if you still have this issue.

    Looking for users to test our releases, interested? send me a PM

Similar Threads

  1. Access denied or Connection failed, using socket: 'file:///var/run/zarafa'
    By frifri in forum Administration and Integration
    Replies: 5
    Last Post: 11-04-2015, 04:28 AM
  2. zarafa /dev/sda6 excessive disk space usage
    By matt_tech in forum Installation, Configuration and Maintenance
    Replies: 2
    Last Post: 19-03-2013, 11:35 AM
  3. Inporting Calendar items in Zarafa makes them 'Private'
    By dimeglio in forum Outlook usage Archives
    Replies: 1
    Last Post: 21-02-2010, 03:26 PM
  4. Permissions of zarafa-licensed socket
    By anton in forum Beta Feedback Archives
    Replies: 1
    Last Post: 14-10-2008, 08:47 AM
  5. [Solved] webaccess unusable with german translation
    By richardw in forum WebAccess usage Archives
    Replies: 5
    Last Post: 20-09-2008, 05:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •