Results 1 to 5 of 5

Thread: Future Zarafa & php version(s) > 5.3.3?

  1. #1
    Junior Member
    Join Date
    Dec 2013
    Posts
    8

    Question Future Zarafa & php version(s) > 5.3.3?

    Hi everybody,

    I'm curious; after I'm currently limited on my Company Server to a specific Version of php (5.3.3), does anybody know if the upcoming 7.2 Version of Zarafa Suite will have a dependency on newer php Versions?

    That would prevent me from upgrading and I'd have to stick to the 7.1.xx line of products...

    Thanks in advance

    Johannes

  2. #2
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Hello Johannes,

    Zarafa and php-mapi will always be built against the distributions default php version. So if your distribution only comes with php 5.3.3 then Zarafa 7.2 will also require 5.3.3. If you want to use a newer php, then you should switch to a distribution providing this version by default.
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  3. #3
    Junior Member davodego's Avatar
    Join Date
    Feb 2014
    Location
    Kranichfeld, Thüringen, Germany
    Posts
    16
    I have Zarafa 7.2.3 on ubuntu 14.04. I want to upgrade my php version from 5.5 to 5.7 for owncloud.
    If I try apt will allways remove all zarafa packages.
    Is thre a workaround or something?
    can I install php5.7 and then reinstall zarafa again?

  4. #4
    Zarafa

    Join Date
    Jan 2009
    Location
    Hanover, Germany
    Posts
    1,891
    Hello Davodego,

    the php-mapi extension is always bound to a specific php version, so you won't be able to reinstall after upgrading php. If you want to run a php version different to the distribution standard you have to compile php-mapi yourself.

    For you specific use case I would recommend to run owncloud on a different system, maybe in docker (there are some maintained docker images for owncloud)
    Regards Felix

    How to get Kopano

    Zarafa ALPHA/BETA/RC feedback in BETA forum please.
    Zarafa IRC chat: irc.freenode.com > #zarafa
    Zarafa documentation: http://documentation.zarafa.com/

    No support via PM! Please contact our sales team for an offer if you want my full attention.

  5. #5
    Junior Member davodego's Avatar
    Join Date
    Feb 2014
    Location
    Kranichfeld, Thüringen, Germany
    Posts
    16
    Thanks for your reply.
    Then I let it like it is. Never change an running system
    With Docker I have no experience an no time to learn it now.
    Daniel

Similar Threads

  1. Replies: 0
    Last Post: 26-03-2014, 09:21 PM
  2. Z-Push 1 future
    By manfred in forum Z-Push when using Kopano/Zarafa
    Replies: 0
    Last Post: 28-06-2012, 04:58 PM
  3. Plan Spreed date in the future
    By ebogaard in forum WebAccess
    Replies: 2
    Last Post: 02-05-2012, 12:22 PM
  4. After installing new Webaccess version still the old version
    By Montesuma in forum Installation and Configuration Archives
    Replies: 1
    Last Post: 20-02-2009, 02:45 PM
  5. Questions / Requests regarding future deployment
    By heutger in forum Beta Feedback Archives
    Replies: 1
    Last Post: 20-02-2008, 07:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •