Page 1 of 9 123 ... LastLast
Results 1 to 10 of 83

Thread: Update Issue

  1. #1
    Member zaraf's Avatar
    Join Date
    Feb 2013
    Location
    Germany
    Posts
    41

    Update Issue

    Hy choffman,

    My System
    Ubuntu 14.04
    Zarafa 7.1.11-46050
    yaffas 1.4.0-1-gc1b39f7

    i have a Problem with a update from yaffas

    ./


    (Lese Datenbank ... 75744 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../zarafa-webapp_1%3a1.6-46049_all.deb ...
    ERROR: Site zarafa-webapp does not exist!
    Entpacken von zarafa-webapp (1:1.6-46049) über (2.0.47678) ...
    dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/zarafa-webapp_1%3a1.6-46049_all.deb (--unpack):
    Versuch, »/usr/share/zarafa-webapp/plugins/oauthlib/manifest.xml« zu überschreiben, welches auch in Paket zarafa-webapp-oauthlib 2.0.47678 ist
    dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
    ERROR: Site zarafa-webapp does not exist!
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/zarafa-webapp_1%3a1.6-46049_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Why zarafa-webapp 1:1.6-46049 Version include?

    regards

    oder auf deutsch (english war wohl nix)

    Ich bekomme folgendes Problem beim update von yaffas

    (Lese Datenbank ... 75744 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../zarafa-webapp_1%3a1.6-46049_all.deb ...
    ERROR: Site zarafa-webapp does not exist!
    Entpacken von zarafa-webapp (1:1.6-46049) über (2.0.47678) ...
    dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/zarafa-webapp_1%3a1.6-46049_all.deb (--unpack):
    Versuch, »/usr/share/zarafa-webapp/plugins/oauthlib/manifest.xml« zu überschreiben, welches auch in Paket zarafa-webapp-oauthlib 2.0.47678 ist
    dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
    ERROR: Site zarafa-webapp does not exist!
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/zarafa-webapp_1%3a1.6-46049_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Wie ist der Zeitplan von yaffas / Z-admin beta zur final Veröffentlichung?

    danke
    Last edited by zaraf; 21-02-2015 at 06:29 PM.
    Produktiv System
    Ubuntu 12.04.05
    yaffas 1.5.0-5-g360b8cb
    Zarafa 7.1.14-51822
    Webapp 2.1.0.51748

    Test System
    Ubuntu 14.04.04
    yaffas 1.5.0-5-g79b3c11
    Zarafa 7.1.14-51822
    Webapp 2.2.0.414-185.1

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    The issue with WebApp is due do a packaging problem with the official packages (there is a thread about this issue). We can try to remove the webapp 1.6 package from our repo, maybe this helps in your case. I will let you know when the change has been implemented.

    No concrete dates for a final version, sorry.

  3. #3
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Repository has been rebuilt without zarafa-webapp 1.6; can you retry?
    (Note: this has only been changed in the Ubuntu 14.04/trusty daily repo)

  4. #4
    Member zaraf's Avatar
    Join Date
    Feb 2013
    Location
    Germany
    Posts
    41
    thanks choffman,

    i've tested it. The Error ist gone but now no packet has been updated!? Than i have Ubuntu 14.04 new installed and there everything is ok.
    I have the same Problem (zarafa-webapp_1%3a1.6-46049_all.deb) with a Ubuntu 12.04 System. Do we try this?

    thanks

    German

    Ich habe es getestet. Der 1%3 Fehler war zwar weg aber Web App wurde nicht auf die in der Repo verfügbaren Version gepatcht. Daraufhin habe ich Ubuntu 14.04 mit yaffas neu installiert da war dann alles ok.
    Ich habe aber das gleiche Problem mit Ubuntu 12.04 Version, wollen wir es damit noch testen?

    danke
    Produktiv System
    Ubuntu 12.04.05
    yaffas 1.5.0-5-g360b8cb
    Zarafa 7.1.14-51822
    Webapp 2.1.0.51748

    Test System
    Ubuntu 14.04.04
    yaffas 1.5.0-5-g79b3c11
    Zarafa 7.1.14-51822
    Webapp 2.2.0.414-185.1

  5. #5
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hi,

    The fact that no automatic update to webapp-2.x happens is due to the packaging issue with the official packages, see ; I can try to reach someone from Zarafa through another channel tomorrow. As far as I understand, this is nothing we can fix without rebuilding our own WebApp packages, which we are not keen on...

    Meanwhile, you could try this:
    Please report back whether this works. Running apt-get upgrade afterwards may still try to "upgrade" to WebApp-1.6, but hopefully not (as it is removed).

    There will most likely be no difference on Ubuntu 12.04, except that I have not removed the old version from the repo yet.

    Kind regards,

    Christian

  6. #6
    Member zaraf's Avatar
    Join Date
    Feb 2013
    Location
    Germany
    Posts
    41
    Hi,

    it worked, but those are major problems with Updates package.
    It's a great pity the zarafa yaffas not better supported. As a result, customers go to MS lost. (MS Exchange or Dreckschange

    german

    Das hat funktioniert aber es scheinen sich ja große Probleme mit den Update Packages auf zu tun.
    Ich bin enttäuscht das Zarafa yaffas nicht besser unterstützt denn dadurch verliert ihr Kunden an Microsoft. Ich kenne Kunden die wechseln wollen oder was gleichwertiges suchen.
    (Da die Admin GUI aber ins stocken gekommen ist kann man das Gesamtpaket nicht empfehlen und das ist schrecklich!!!)

    regards
    Produktiv System
    Ubuntu 12.04.05
    yaffas 1.5.0-5-g360b8cb
    Zarafa 7.1.14-51822
    Webapp 2.1.0.51748

    Test System
    Ubuntu 14.04.04
    yaffas 1.5.0-5-g79b3c11
    Zarafa 7.1.14-51822
    Webapp 2.2.0.414-185.1

  7. #7
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    The packaging problem has been noticed by us only recently and we have not contacted Zarafa directly regarding this issue.
    This is one of the showstoppers for a new yaffas release, yes, but there are possible workarounds which we could employ (although they'd be rather hacky). It should still be possible to provide a fully working package.

  8. #8
    Member zaraf's Avatar
    Join Date
    Feb 2013
    Location
    Germany
    Posts
    41
    i pray for you
    Ich bete für euch!

    thx
    Produktiv System
    Ubuntu 12.04.05
    yaffas 1.5.0-5-g360b8cb
    Zarafa 7.1.14-51822
    Webapp 2.1.0.51748

    Test System
    Ubuntu 14.04.04
    yaffas 1.5.0-5-g79b3c11
    Zarafa 7.1.14-51822
    Webapp 2.2.0.414-185.1

  9. #9
    Member zaraf's Avatar
    Join Date
    Feb 2013
    Location
    Germany
    Posts
    41
    Hi,
    I have now done several tests. It is definitely on the webapp () package. Any news from this direction?
    choffman what could you achieve with the developers of webapp?

    regards

    german

    Ich habe nun mehrere Tests durchgeführt (Ubuntu 12.04 samt yaffas neu installiert apt-get und dpkg install). Es liegt an dem Paket von webapp 2.*. Neuste Version installiert danach apt-get upgrade will immer ein downgrade auf 1.6??? (von 2 auf 1.6 downgrade!!!)
    (Komischerweise wird yaffas auch nicht von 1.4.0-1-g88ee371 auf die gf84cfc4 gehoben!!!)

    choffmann konntest du etwas mit den Entwicklern von Webapp erreichen?

    Danke!
    Last edited by zaraf; 28-02-2015 at 06:19 PM.
    Produktiv System
    Ubuntu 12.04.05
    yaffas 1.5.0-5-g360b8cb
    Zarafa 7.1.14-51822
    Webapp 2.1.0.51748

    Test System
    Ubuntu 14.04.04
    yaffas 1.5.0-5-g79b3c11
    Zarafa 7.1.14-51822
    Webapp 2.2.0.414-185.1

  10. #10
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hi,

    yes, I got quick feedback from Zarafa and it was suggested that we try to implement this using dependencies, so it's actually my turn to do some tests there...

    Kind regards,

    Christian

Page 1 of 9 123 ... LastLast

Similar Threads

  1. 7.1.11 Packaging Issue on EL5
    By luis in forum Installation, Configuration and Maintenance
    Replies: 2
    Last Post: 28-08-2014, 10:05 AM
  2. character issue
    By alismanis in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 20-09-2013, 08:57 AM
  3. Issue on quota after 6.3.10 update
    By dariofinardi in forum Administration and Integration Archives
    Replies: 2
    Last Post: 25-02-2010, 01:55 PM
  4. Big issue with 6.05
    By dtraenapp in forum Outlook usage Archives
    Replies: 11
    Last Post: 09-12-2008, 05:17 PM
  5. Timezone issue
    By desdougan in forum Installation and Configuration Archives
    Replies: 2
    Last Post: 01-11-2008, 05:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •