Results 1 to 5 of 5

Thread: Send As Permission configuration error

  1. #1
    Junior Member
    Join Date
    Feb 2013
    Posts
    11

    Send As Permission configuration error

    Community

    I am having problems configuring send as rights for mailboxes
    In the webapp and or z-admin configuration I checked if a certain user has the proper rights assigned to him.
    But when I check with cli command

    zarafa-admin --list-sendas info

    no user is being displayed

    When i try to configure the send as right with cli

    zarafa-admin -u info --add-sendas xxxx

    "Unable to update user, unable to update sendas list, action not supported by server "

    I am using local authentication on my Z-admin server
    Product

    Version Z-Admin : 1.3.2-5-g8d319be
    Zarafa : 7.1.8-44004
    Ubuntu : Ubuntu 12.04.4 LTS

    I searched the forum for solution but could not find any suitable.
    Any help is greatly appreciated

    Edwin

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hi Edwin,

    --add-sendas not working is expected due to the LDAP backend (only works for MySQL, iirc).

    Have you tried switching the entries? I cannot remember the proper "direction" off hand either, so it may be worth a try.

    Kind regards,

    Christian

  3. #3
    Junior Member
    Join Date
    Feb 2013
    Posts
    11
    Christian
    Thanks for the response. I did not know that
    Can you clarify a little bit by what you mean with switching entries? I am an newbie when I comes down to changing ldap settings

    The only settings that I could find regarding sendas in my ldap.yaffas.cfg are the following

    ldap_sendas_attribute_type = dn
    ldap_sendas_relation_attribute = distinguishedName

  4. #4
    Senior Member
    Join Date
    Dec 2012
    Posts
    267
    Hi Edwin,

    Sorry for not being clearer in the first attempt, I was a bit in a hurry.

    zarafa-admin --list-sendas info should show you all the users who are allowed to send as user info.

    Can you confirm that you edited the relevant user (e.g. "john") and selected the "info" entry in the "Allow send as" field?

    By switching entries I meant: Try it the other way round (adding the user info to john's sendas list vs. adding john to info's sendas list).
    However, a quick test shows that adding "info" to john's list should be right.

    Please note that this only applies to the Z-Admin UI. It may be different on the command line (especially since this direction changed between ZCP 6.40 and 7.x).

    Kind regards,

    Christian

  5. #5
    Junior Member
    Join Date
    Feb 2013
    Posts
    11
    Christian

    I want you to know that it is working now. In the webapp using the account info I went to settings Deletegated Control and gave John ownership. After that John is able to send as info user. The send as option under settings was not enough to get it to work. However I noticed when I set this up also, the recipient receives the message with the -on belf of- extension in sender field.

    Thank you for your time

Similar Threads

  1. send as permission don't work with rules
    By troublestarterx in forum Administration and Integration
    Replies: 0
    Last Post: 14-08-2013, 04:25 PM
  2. BesX: send-as permission problems for syncing calendar to server from Blackberry
    By halfgaar in forum Installation, Configuration and Maintenance
    Replies: 8
    Last Post: 24-07-2012, 01:42 PM
  3. (Solved) Group permission to send as a user does not work
    By mniehren in forum Installation, Configuration and Maintenance
    Replies: 21
    Last Post: 16-11-2011, 09:02 AM
  4. [solved] How to configure 'Send As' Permission?
    By ehoefler in forum WebAccess usage Archives
    Replies: 24
    Last Post: 03-03-2011, 08:15 AM
  5. calendar permission error in 6.40.4
    By datenhain in forum Other mail/calendar clients Archives
    Replies: 5
    Last Post: 09-02-2011, 02:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •