Results 1 to 8 of 8

Thread: Mobile device management not showing any device

  1. #1

    Mobile device management not showing any device

    Ticket was created at


    Hey everyone.

    Facts:
    Linux: 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux
    Zarafa: 7.1.10
    Z-Push: z-push-2.1.2-1873
    Everything is patched up to date

    Today I just discovered that the Webaccess MDM plugin does not show any devices for none of the clients. It worked in the past, but I have to admit, I do not know exactly when it stopped working, since it is luckily not a commonly used feature ;-) Zarafa works, mobile devices can connect via Z-Push, webaccess works, just the MDM section is empty.

    I recieve the following error message. The interesting thing is, that I am logged in into the webaccess site, consequently webaccess is providing some bad credentials.

    Hint:
    Roughly 1-2 years ago there was a problem with my auth system (Kerberos), when Z-Push changed for some reasons to lowername conventions. My auth system (for security reasons) is still checking for uppercase and lowercase correctness. Might this be a sideffect?

    To whom do I address this issue, to Z-Push or Webaccess or the MDM section?

    Help of any kind is welcome.

    Cheers.
    Last edited by hzr345; 24-06-2014 at 05:35 PM. Reason: Added reference to ticket post

  2. #2
    Junior Member
    Join Date
    Aug 2014
    Posts
    1
    Hi,

    i've the same issue and couldn't resolve it yet, BUT - if you insert in the mobile phone mail account settings instead the "user" the "e-mail" adress - the error does not exist in the z-push.log anymore.
    You can see a new message including a correct device type and devid - this seems correct.

    Maybe they have a parameter mismatch in the Z-Push Version (2.1.3-1892)

    But you will not be able to connect to the ZCP Backend

  3. #3
    Zarafa Development

    Join Date
    Mar 2014
    Posts
    49
    I think this patch should fix the authentication issue. File to patch is plugin.mdm.php
    patch -Np2 -i mdm_login.patch should do the trick (if you are in webaccess-plugins/mdm/ )
    Last edited by jelle; 18-08-2014 at 01:12 PM.

  4. #4
    Hey Jelle.

    Sorry for my late reply. Unfortunately this patch did not work. First I could not patch as described by you. However, I just did it manually. And if I did not make any mistake (The patch does not include so much code ;-)) I just got a white screen in webacces without any errors in the logs. Maybe I have the wrong versions installed, although all of them are up to date (zarafa-webaccess_7.1.11-45875 and mdm should be 2.1 - there is no version number in the source code)???

    Any ideas? Kind regards, Fritz

  5. #5
    Junior Member
    Join Date
    Jul 2013
    Posts
    13
    The patch provided at fixed the problem with MDM 2.1 on ZCP 711 for me.

  6. #6
    Hey Jelle.

    I just wanted to let you know that i retried to install your patch (e.g. I used the above link provided by geegee) and it worked. I only had a tiny problem to patch it via "patch" command. I got the following error:

    However, just entering the file to patch solved the problem. Afterwards everything worked like a charm ;-) Thank you very much!

    Cheers, Fritz

    P.S.: I used zarafa-webaccess_7.1.11-45875 and z-push-2.2.0-1934.

  7. #7
    Junior Member
    Join Date
    Jul 2013
    Posts
    13

    patch code provided here


    Let's make sure that everyone can find the patch in the future too.
    Here are the contents of the file linked two messages above:


  8. #8
    Senior Member
    Join Date
    Feb 2008
    Location
    Leonberg, Germany
    Posts
    273
    The patch IMHO should use rtrim(..., "\0") rather trim() otherwise leading or trailing spaces might be removed as well, see also my for WebAccess itself.
    Last edited by rsc; 29-03-2015 at 02:10 PM. Reason: Added link to example patch

Similar Threads

  1. WebApp Mobile Device Management
    By peterbeck in forum WebApp
    Replies: 2
    Last Post: 23-09-2013, 03:28 PM
  2. Mobile loop detection & connection begans to fail on mobile device
    By tehsu in forum Z-Push when using Kopano/Zarafa
    Replies: 3
    Last Post: 12-05-2013, 12:25 PM
  3. Mobile Device Management 2.1 language/localisation
    By slapnutcity in forum Z-Push when using Kopano/Zarafa
    Replies: 1
    Last Post: 06-08-2012, 04:28 PM
  4. Mobile device policies
    By divB in forum Installation, Configuration and Maintenance
    Replies: 1
    Last Post: 20-07-2012, 12:53 AM
  5. Remove mobile device
    By Romep in forum Installation and Configuration Archives
    Replies: 3
    Last Post: 16-02-2011, 05:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •