I agree with manfred you have to install a new version from debian packages and restart the agent.